diff mbox series

[bug#59389,26/26] gnu: Add pastel.

Message ID 20221119184533.22976-26-jgart@dismail.de
State New
Headers show
Series [bug#59389,01/26] gnu: Add rust-windows-x86-64-gnullvm-0.42. | expand

Commit Message

jgart Nov. 19, 2022, 6:45 p.m. UTC
* gnu/packages/rust-apps.scm (pastel): New variable.
---
 gnu/packages/rust-apps.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 693489264d..fbb12b4a1e 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2026,6 +2026,42 @@  (define-public git-absorb
 It will then write @code{fixup!} commits for each of those changes.")
     (license license:bsd-3)))
 
+(define-public pastel
+  (package
+    (name "pastel")
+    (version "0.9.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "pastel" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1fjlw8np2bx0i1hk6lfq5swiif6ilj9f270vfh8yr62apq704g0f"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-atty" ,rust-atty-0.2)
+                       ("rust-clap" ,rust-clap-3)
+                       ("rust-clap" ,rust-clap-3)
+                       ("rust-clap-complete" ,rust-clap-complete-3)
+                       ("rust-nom" ,rust-nom-7)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-once-cell" ,rust-once-cell-1)
+                       ("rust-output-vt100" ,rust-output-vt100-0.1)
+                       ("rust-output-vt100" ,rust-output-vt100-0.1)
+                       ("rust-rand" ,rust-rand-0.8)
+                       ("rust-regex" ,rust-regex-1))
+       #:cargo-development-inputs (("rust-approx" ,rust-approx-0.5)
+                                   ("rust-assert-cmd" ,rust-assert-cmd-2)
+                                   ("rust-criterion" ,rust-criterion-0.3)
+                                   ("rust-rand-xoshiro" ,rust-rand-xoshiro-0.6))))
+    (home-page "https://github.com/sharkdp/pastel")
+    (synopsis
+     "A command-line tool to generate, analyze, convert and manipulate colors")
+    (description
+     "This package provides a command-line tool to generate, analyze, convert and
+manipulate colors")
+    (license (list license:expat license:asl2.0))))
+
 (define-public zoxide
   (package
     (name "zoxide")