diff mbox series

[bug#59354] gnu: Add texlive-mathdots.

Message ID 20221118102010.86581-1-yarl-baudig@mailoo.org
State New
Headers show
Series [bug#59354] gnu: Add texlive-mathdots. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

yarl baudig Nov. 18, 2022, 10:20 a.m. UTC
* gnu/packages/tex.scm (texlive-mathdots): New variable.
---
 gnu/packages/tex.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)


base-commit: 1bea5d38a26755b84437623c0f48915a77899b57

Comments

Nicolas Goaziou Nov. 19, 2022, 9:32 a.m. UTC | #1
Hello,

Yarl Baudig <yarl-baudig@mailoo.org> writes:

> * gnu/packages/tex.scm (texlive-mathdots): New variable.

Thank you. Some comments follow.

> +  (package
> +    (inherit (simple-texlive-package
> +	      "texlive-mathdots"

Indentation looks wrong here.

> +              (list "doc/generic/mathdots/"
> +                    "source/generic/mathdots/"
> +                    "tex/generic/mathdots/")
> +              (base32
> +               "1jaffj343p1chdxs2g7s6lpckvihk0jfw22nw0vmijyjxfiy9yg0")
> +	      #:trivial? #t))

This doesn't look like a trivial package since it contains a ".ins"
file. You need to generate the ".tex" and ".sty" files from it.

> +   (home-page "https://ctan.org/macros/generic/mathdots")
> +   (synopsis "Commands to produce dots in math that respect font size")
> +   (description
> +    "Redefines \\ddots and \\vdots, and defines \\iddots.  The dots produced by \\iddots

The first sentence should contain a subject. Also \\ddots ->
@code{\\dots}

Could you send an updated patch?

Regards,
yarl baudig Nov. 19, 2022, 3:02 p.m. UTC | #2
Hello,

> Thank you. Some comments follow.
> 
> > +  (package
> > +    (inherit (simple-texlive-package
> > +	      "texlive-mathdots"
> 
> Indentation looks wrong here.
I am not sure how it's wrong. Path will follow. Is it better?

> 
> > +              (list "doc/generic/mathdots/"
> > +                    "source/generic/mathdots/"
> > +                    "tex/generic/mathdots/")
> > +              (base32
> > +               "1jaffj343p1chdxs2g7s6lpckvihk0jfw22nw0vmijyjxfiy9yg0")
> > +	      #:trivial? #t))
> 
> This doesn't look like a trivial package since it contains a ".ins"
> file. You need to generate the ".tex" and ".sty" files from it.
> 
I think it is, "tex/generic/mathdots/" in tug repo contains ".tex" and ".sty" and if I compile, they are here.
First texlive package I package. I tried `guix import texlive mathdots` then amended by looking at other texlive packages. Please show me if I am wrong.

> > +   (home-page "https://ctan.org/macros/generic/mathdots")
> > +   (synopsis "Commands to produce dots in math that respect font size")
> > +   (description
> > +    "Redefines \\ddots and \\vdots, and defines \\iddots.  The dots 
> produced by \\iddots
> 
> The first sentence should contain a subject. Also \\ddots ->
> @code{\\dots}
> 
> Could you send an updated patch?
> 
> Regards,
> -- 
> Nicolas Goaziou
> 

Patch is coming, please tell me if it good.
Nicolas Goaziou Nov. 20, 2022, 3:47 p.m. UTC | #3
Hello,

"yarl baudig" <yarl-baudig@mailoo.org> writes:

> I am not sure how it's wrong. Path will follow. Is it better?

It is. Thanks.

>> This doesn't look like a trivial package since it contains a ".ins"
>> file. You need to generate the ".tex" and ".sty" files from it.
>> 
> I think it is, "tex/generic/mathdots/" in tug repo contains ".tex" and ".sty" and if I compile, they are here.
> First texlive package I package. I tried `guix import texlive
> mathdots` then amended by looking at other texlive packages. Please
> show me if I am wrong.

"guix import texlive mathdots" output doesn't include "#:trivial? #t"
for a reason. You need to take a longer path and generate runfiles from
the ".ins" file ; see e.g., "texlive-capt-of".

Regards,
yarl baudig Nov. 20, 2022, 4:24 p.m. UTC | #4
> >> This doesn't look like a trivial package since it contains a ".ins"
> >> file. You need to generate the ".tex" and ".sty" files from it.
> >> 
> > I think it is, "tex/generic/mathdots/" in tug repo contains ".tex" and 
> ".sty" and if I compile, they are here.
> > First texlive package I package. I tried `guix import texlive
> > mathdots` then amended by looking at other texlive packages. Please
> > show me if I am wrong.
> 
> "guix import texlive mathdots" output doesn't include "#:trivial? #t"
> for a reason. You need to take a longer path and generate runfiles from
> the ".ins" file ; see e.g., "texlive-capt-of".
> 
> Regards,
> -- 
> Nicolas Goaziou
> 

Thank you.
I saw that "guix import texlive mathdots" doesn't include "#:trivial? #t" But I still don't see why it is not effectively a trivial package. As I told you, the ".tex" and ".sty" are already in the TUG repo. And with the package as I defined it (as trivial), when you build it, you get the "mathdots.sty" and "mathdots.tex". No need to compile because, whereas there is a ".ins" file,  ".sty" and ".tex" are already compiled and distributed, along the ".ins". Right?
Nicolas Goaziou Nov. 20, 2022, 4:46 p.m. UTC | #5
"yarl baudig" <yarl-baudig@mailoo.org> writes:

> I saw that "guix import texlive mathdots" doesn't include "#:trivial?
> #t" But I still don't see why it is not effectively a trivial package.
> As I told you, the ".tex" and ".sty" are already in the TUG repo. And
> with the package as I defined it (as trivial), when you build it, you
> get the "mathdots.sty" and "mathdots.tex". No need to compile because,
> whereas there is a ".ins" file, ".sty" and ".tex" are already compiled
> and distributed, along the ".ins". Right?

Whenever possible, Guix builds packages from source, and avoids using
pre-compiled files. In this case, we can generate ".sty" and ".tex"
files, so let's do that. Does that make sense?
yarl baudig Nov. 20, 2022, 5:16 p.m. UTC | #6
> Whenever possible, Guix builds packages from source, and avoids using
> pre-compiled files. In this case, we can generate ".sty" and ".tex"
> files, so let's do that. Does that make sense?
> 

Yes it does! Thank you. I will try :).
diff mbox series

Patch

diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 81f74f17df..f901d80bf8 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3993,6 +3993,25 @@  (define-public texlive-amsmath
 
 (define-deprecated-package texlive-latex-amsmath texlive-amsmath)
 
+(define-public texlive-mathdots
+  (package
+    (inherit (simple-texlive-package
+	      "texlive-mathdots"
+              (list "doc/generic/mathdots/"
+                    "source/generic/mathdots/"
+                    "tex/generic/mathdots/")
+              (base32
+               "1jaffj343p1chdxs2g7s6lpckvihk0jfw22nw0vmijyjxfiy9yg0")
+	      #:trivial? #t))
+   (home-page "https://ctan.org/macros/generic/mathdots")
+   (synopsis "Commands to produce dots in math that respect font size")
+   (description
+    "Redefines \\ddots and \\vdots, and defines \\iddots.  The dots produced by \\iddots
+slant in the opposite direction to \\ddots.  All the commands are designed to
+change size appropriately in scripts, as well as in response to LaTeX size
+changing commands.  The commands may also be used in plain TeX.")
+   (license license:lppl)))
+
 (define-public texlive-amscls
   (let ((template (simple-texlive-package
                    "texlive-amscls"