diff mbox series

[bug#59327] gnu: python-pudb: Add missing python-numpy native-input.

Message ID 20221117014833.19943-1-jgart@dismail.de
State New
Headers show
Series [bug#59327] gnu: python-pudb: Add missing python-numpy native-input. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 17, 2022, 1:48 a.m. UTC
* gnu/packages/python-xyz.scm (python-pudb): Add missing native-input.
[native-inputs]: Add python-numpy.
---
 gnu/packages/python-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Christopher Baines Nov. 21, 2022, 12:10 p.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-xyz.scm (python-pudb): Add missing native-input.
> [native-inputs]: Add python-numpy.
> ---
>  gnu/packages/python-xyz.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)

What I'm missing here is why you're making the change? It looks to me
that the package builds without python-numpy?

Thanks,

Chris
jgart Nov. 21, 2022, 2:34 p.m. UTC | #2
On Mon, 21 Nov 2022 12:10:08 +0000 Christopher Baines <mail@cbaines.net> wrote:
>
> What I'm missing here is why you're making the change? It looks to me
> that the package builds without python-numpy?

Hi,

Does test_get_stringifier currently pass or get ignored in the pudb
package's check phase?

https://github.com/inducer/pudb/blob/v2022.1.3/test/test_var_view.py#L28

I'll check later today and report back.
jgart Nov. 21, 2022, 2:38 p.m. UTC | #3
On Mon, 21 Nov 2022 08:34:50 -0600 jgart <jgart@dismail.de> wrote:
> I'll check later today and report back.

Oh, that test just passes an empty list if numpy is not available:

https://github.com/inducer/pudb/blob/v2022.1.3/test/test_var_view.py#L32

Do we want to run that test with our packaged numpy on [np.float32(5), np.zeros(5)]?

all best,

jgart
Christopher Baines Nov. 22, 2022, 9:38 a.m. UTC | #4
jgart <jgart@dismail.de> writes:

> On Mon, 21 Nov 2022 08:34:50 -0600 jgart <jgart@dismail.de> wrote:
>> I'll check later today and report back.
>
> Oh, that test just passes an empty list if numpy is not available:
>
> https://github.com/inducer/pudb/blob/v2022.1.3/test/test_var_view.py#L32
>
> Do we want to run that test with our packaged numpy on [np.float32(5),
> np.zeros(5)]?

That seems fine to me, I've tweaked the commit message to describe it as
an "optional test dependency", rather than "missing". and pushed to
master as eda5e9aaafeacc0e21dbf43200d79b91fc1e38ed.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index a6b1c7e27e..0968f1477f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29153,7 +29153,7 @@  (define-public python-pudb
                     (lambda* (#:key tests? #:allow-other-keys)
                       (when tests?
                         (invoke "pytest" "-vv")))))))
-    (native-inputs (list python-pytest python-pytest-mock))
+    (native-inputs (list python-pytest python-pytest-mock python-numpy))
     (propagated-inputs (list python-jedi python-pygments python-urwid
                              python-urwid-readline))
     (home-page "https://documen.tician.de/pudb/")