diff mbox series

[bug#59281] gnu: Add python-dm-tree.

Message ID 20221115200305.17761-1-ngraves@ngraves.fr
State New
Headers show
Series [bug#59281] gnu: Add python-dm-tree. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Nicolas Graves Nov. 15, 2022, 8:03 p.m. UTC
* gnu/packages/python-xyz.scm (python-dm-tree): New variable.
---
 gnu/packages/python-xyz.scm | 68 +++++++++++++++++++++++++++++++++++++
 1 file changed, 68 insertions(+)

Comments

Ludovic Courtès Nov. 28, 2022, 10:29 p.m. UTC | #1
Hi,

Nicolas Graves <ngraves@ngraves.fr> skribis:

> * gnu/packages/python-xyz.scm (python-dm-tree): New variable.

Applied with cosmetic changes, primarily to remove the hardcoded “3.9”
Python version number.

Thanks,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1758450c2f..fafacc4d94 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -131,6 +131,7 @@ 
 ;;; Copyright © 2022 Mathieu Laparie <mlaparie@disr.it>
 ;;; Copyright © 2022 Garek Dyszel <garekdyszel@disroot.org>
 ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
+;;; Copyright © 2022 Nicolas Graves <ngraves@ngraves.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -159,6 +160,7 @@  (define-module (gnu packages python-xyz)
   #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cpp)
   #:use-module (gnu packages crypto)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages dbm)
@@ -4618,6 +4620,72 @@  (define-public autokey
 flexibility and power of the Python language.")
     (license license:gpl3+)))
 
+(define-public python-dm-tree
+  (package
+    (name "python-dm-tree")
+    (version "0.1.7")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "dm-tree" version))
+       (sha256
+        (base32 "0apxfxgmqh22qpk92zmmf3acqkavhwxz78lnwz026a5rlnncizih"))))
+    (build-system python-build-system)
+    (inputs (list pybind11 abseil-cpp python))
+    (propagated-inputs (list python-wheel
+                         python-absl-py
+                         python-attrs
+                         python-numpy
+                         python-wrapt))
+    (arguments
+     (list
+      #:tests? #f
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'build 'build-shared-lib
+            (lambda _
+              (let* ((pybind11   #$(this-package-input "pybind11"))
+                     (python     #$(this-package-input "python"))
+                     (abseil-cpp #$(this-package-input "abseil-cpp")))
+                ;; Delete default cmake build.
+                (substitute* "setup.py"
+                  (("ext_modules.*") "")
+                  (("cmdclass.*") ""))
+                ;; Actual build phase.
+                (mkdir-p "build/temp/tree/")
+                (invoke
+                 "gcc" "-pthread" "-Wno-unused-result" "-Wsign-compare"
+                 "-DNDEBUG" "-g" "-fwrapv" "-O3" "-Wall"
+                 "-fno-semantic-interposition" "-fPIC"
+                 "-I" (string-append
+                       pybind11 "/lib/python3.9/site-packages/pybind11/include")
+                 "-I" (string-append python "/include/python3.9")
+                 "-I" (string-append abseil-cpp "/include")
+                 "-c" "tree/tree.cc"
+                 "-o" "build/temp/tree/tree.o"
+                 "-fvisibility=hidden" "-g0")
+                (mkdir-p "build/lib/tree")
+                (invoke
+                 "g++" "-pthread" "-shared"
+                 (string-append "-Wl," "-rpath=" python "/lib")
+                 "-fno-semantic-interposition"
+                 "build/temp/tree/tree.o"
+                 "-L" (string-append python "/lib")
+                 "-L" (string-append abseil-cpp "/lib")
+                 "-l" "absl_int128"
+                 "-l" "absl_raw_hash_set"
+                 "-l" "absl_raw_logging_internal"
+                 "-l" "absl_strings"
+                 "-l" "absl_throw_delegate"
+                 "-o" "build/lib/tree/_tree.so")))))))
+    (home-page "https://github.com/deepmind/tree")
+    (synopsis "Work with nested data structures in python.")
+    (description "Tree is a python library for working with nested
+data structures. In a way, @code{tree} generalizes the builtin map
+function which only supports flat sequences, and allows to apply a
+function to each leaf preserving the overall structure.")
+    (license license:asl2.0)))
+
 (define-public python-docutils
   (package
     (name "python-docutils")