diff mbox series

[bug#59244] services: vpn: Fix type used for profile-service-type

Message ID 20221113104630.15128-1-eu@euandre.org
State New
Headers show
Series [bug#59244] services: vpn: Fix type used for profile-service-type | expand

Checks

Context Check Description
cbaines/applying patch fail
cbaines/issue success View issue
cbaines/applying patch fail
cbaines/issue success View issue

Commit Message

EuAndreh Nov. 13, 2022, 10:46 a.m. UTC
* gnu/services/vpn.scm (wireguard-service-type): Use a list of packages
  for extending profile-service-type instead of the package directly.
---

Right now it gives an error at build time:

  In procedure append: Wrong type argument in position 15 (expecting empty list): #<package wireguard-tools@1.0.20210914 gnu/packages/vpn.scm:1093 7fd437f48dc0>

 gnu/services/vpn.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Mathieu Othacehe Nov. 13, 2022, 12:56 p.m. UTC | #1
> * gnu/services/vpn.scm (wireguard-service-type): Use a list of packages
>   for extending profile-service-type instead of the package directly.

Applied, thanks.

Mathieu
EuAndreh Nov. 13, 2022, 2:14 p.m. UTC | #2
Hmm, using the "wireguard-configuration-wireguard" package is much 
better, I didn't see it being defined in the configuration.

Thanks for the improvement :)
diff mbox series

Patch

diff --git a/gnu/services/vpn.scm b/gnu/services/vpn.scm
index 5cdfa97add..20439223c0 100644
--- a/gnu/services/vpn.scm
+++ b/gnu/services/vpn.scm
@@ -877,6 +877,6 @@  (define wireguard-service-type
           (service-extension activation-service-type
                              wireguard-activation)
           (service-extension profile-service-type
-                             (const wireguard-tools))))
+                             (const (list wireguard-tools)))))
    (description "Set up Wireguard @acronym{VPN, Virtual Private Network}
 tunnels.")))