diff mbox series

[bug#59238,2/4] gnu: Add clazy.

Message ID 20221113053709.30530-2-maxim.cournoyer@gmail.com
State New
Headers show
Series Add qt-creator (and supporting packages) | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Maxim Cournoyer Nov. 13, 2022, 5:37 a.m. UTC
* gnu/packages/qt.scm (clazy): New variable.
---
 gnu/packages/qt.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d126c2b09a..408fe35d0a 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -4324,6 +4324,30 @@  (define-public kdsoap
 web server.")
     (license (list license:gpl2 license:gpl3))))
 
+(define-public clazy
+  (package
+    (name "clazy")
+    (version "1.11")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/KDE/clazy")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1y0n1jknq566z1rifkgdm1yqb0mw564lp51jidfz7q9w91spijci"))))
+    (build-system cmake-build-system)
+    (native-inputs (list python))
+    (inputs (list clang llvm))
+    (home-page "https://github.com/KDE/clazy/")
+    (synopsis "Qt-oriented static code analyzer")
+    (description "clazy is a compiler plugin which allows @command{clang} to
+understand Qt semantics.  It can emit more than 50 Qt related compiler
+warnings, ranging from unneeded memory allocations to misusage of API,
+including @i{fix-its} for automatic refactoring.")
+    (license license:lgpl2.0+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar