diff mbox series

[bug#59227] gnu: emacs-forge: Fix build.

Message ID 20221112220746.23845-1-bauermann@kolabnow.com
State New
Headers show
Series [bug#59227] gnu: emacs-forge: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Thiago Jung Bauermann Nov. 12, 2022, 10:07 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-forge): Add ‘inputs’ field.
---

Hello,

This package recently stopped building. Not sure if it was the upgrade of
git or of emacs-magit, but the problem is the lack of the git patckage in
the build environment.

 gnu/packages/emacs-xyz.scm | 2 ++
 1 file changed, 2 insertions(+)

Comments

Thiago Jung Bauermann Nov. 13, 2022, 9:14 p.m. UTC | #1
Thiago Jung Bauermann <bauermann@kolabnow.com> writes:

> This package recently stopped building. Not sure if it was the upgrade of
> git or of emacs-magit, but the problem is the lack of the git patckage in
> the build environment.

Actually, thinking more about it the correct fix is to change Magit to
directly reference the full path of the git executable.

I submitted a patch to that effect in https://issues.guix.gnu.org/59253
so I'm closing this issue.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index edbfb560e80a..98e147a1caf4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -26990,6 +26990,8 @@  (define-public emacs-forge
               (chdir "lisp"))))))
      (native-inputs
       (list texinfo))
+     (inputs
+      (list git))
      (propagated-inputs
       (list emacs-closql
             emacs-dash