diff mbox series

[bug#59211] gnu: copyq: Update to 6.3.2.

Message ID 20221112081304.17017-1-kiasoc5@disroot.org
State New
Headers show
Series [bug#59211] gnu: copyq: Update to 6.3.2. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

kiasoc5 Nov. 12, 2022, 8:13 a.m. UTC
* gnu/packages/xdisorg (copyq): Update to 6.3.2.
[arguments]: Use g-expressions.
[inputs]: Add qtdeclarative-5, qtwayland-5, wayland, knotifications.
[native-inputs]: Add extra-cmake-modules, qttools-5.
---
 gnu/packages/xdisorg.scm | 21 ++++++++++++++++-----
 1 file changed, 16 insertions(+), 5 deletions(-)


base-commit: ad03c2d461100539aec9a32de081a320dce4f50d

Comments

Efraim Flashner Nov. 15, 2022, 9:17 a.m. UTC | #1
Thanks. Patch pushed!
diff mbox series

Patch

diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index c4cc351cad..1d6d1a068b 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -111,6 +111,7 @@  (define-module (gnu packages xdisorg)
   #:use-module (gnu packages haskell-xyz)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages image)
+  #:use-module (gnu packages kde-frameworks)
   #:use-module (gnu packages libbsd)
   #:use-module (gnu packages libevent)
   #:use-module (gnu packages linux)
@@ -358,7 +359,7 @@  (define-public bemenu
 (define-public copyq
 (package
   (name "copyq")
-  (version "3.9.3")
+  (version "6.3.2")
   (source (origin
             (method git-fetch)
             (uri (git-reference
@@ -367,13 +368,23 @@  (define-public copyq
             (file-name (git-file-name name version))
             (sha256
              (base32
-              "0wlwq9xg8rzsbj0b29z358k4mbrqy04iraa8x0p26pa95yskgcma"))))
+              "0qdf7lr6bdmsnz1k5nnzmbv4h0xj8jqg92x6089qdaz5s87x7vqr"))))
   (build-system cmake-build-system)
   (arguments
-   `(#:configure-flags '("-DCMAKE_BUILD_TYPE=Release")
-     #:tests? #f)) ; Test suite is a rather manual process.
+   (list
+    #:configure-flags #~(list "-DCMAKE_BUILD_TYPE=Release")
+    #:tests? #f)) ; Test suite is a rather manual process.
   (inputs
-   (list qtbase-5 qtscript qtsvg-5 qtx11extras))
+   (list qtbase-5
+         qtscript
+         qtsvg-5
+         qtx11extras
+         qtdeclarative-5
+         qtwayland-5
+         wayland
+         knotifications))
+  (native-inputs
+   (list extra-cmake-modules qttools-5))
   (synopsis "Clipboard manager with advanced features")
   (description "CopyQ is clipboard manager with editing and scripting
 features.  CopyQ monitors system clipboard and saves its content in customized