diff mbox series

[bug#59186,v2] gnu: Add emacs-free-keys.

Message ID 20221111130758.27692-1-jgart@dismail.de
State New
Headers show
Series [bug#59186,v2] gnu: Add emacs-free-keys. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 11, 2022, 1:07 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-free-keys): New variable.

Hi Nicolas,

Sorry about that. Here is v2 with the texinfo markup updated.

Is what you're saying that @code markup should never be used to reference
guix code?

all best,

jgart
---
 gnu/packages/emacs-xyz.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)

Comments

Nicolas Goaziou Nov. 12, 2022, 10:46 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-free-keys): New variable.
>
> Sorry about that. Here is v2 with the texinfo markup updated.

Thank you. I moved the package definition outside the end of the file,
changed @code{free-keys} into Free-keys (sorry, I couldn't help) and
applied it.

> Is what you're saying that @code markup should never be used to reference
> guix code?

No, it isn't.

I'm saying that we should not mix the Guix variable name (here
`emacs-free-keys') and the name of the project (here `free-keys'). The
description is more about the project than the Guix variable. Therefore,
we should reference the former, not the latter. As a consequence,
@code{free-keys} is better than @code{emacs-free-keys} because we're not
referencing Guix code.

Also, on a more personal POV, I think we're using emphasis too much in
descriptions as it hinders readability. In particular, @code markup
should really be reserved to symbols (variables, functions…) rather than
project names. Capitalization is much more elegant in this case.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c0faf221d6..b2cf31d3d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33866,6 +33866,28 @@  (define-public emacs-vertico-posframe
 a vertical completion UI.")
     (license license:gpl3+)))
 
+(define-public emacs-free-keys
+  (package
+    (name "emacs-free-keys")
+    (version "1.0.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://github.com/Fuco1/free-keys")
+         (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0xgifa7s9n882f9ymyyz9gc11xfbj3vfpnxiq1fqfm5hmwx9pwbc"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/Fuco1/free-keys")
+    (synopsis "Show free keybindings for modkeys or prefixes")
+    (description
+"@code{free-keys} shows available key bindings in the current
+buffer.")
+    (license license:gpl3+)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar