diff mbox series

[bug#59190] gnu: Add python-pytest-parawtf.

Message ID 20221111063718.24140-1-jgart@dismail.de
State New
Headers show
Series [bug#59190] gnu: Add python-pytest-parawtf. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 11, 2022, 6:37 a.m. UTC
* gnu/packages/python-check.scm (python-pytest-parawtf): New variable.
---
 gnu/packages/python-check.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Efraim Flashner Nov. 15, 2022, 9:16 a.m. UTC | #1
After enabling the test suite I found there were some failed tests.
Also, the bitbucket source is gone, and it seems to have moved to
GitHub.

On Fri, Nov 11, 2022 at 12:37:18AM -0600, jgart via Guix-patches via wrote:
> * gnu/packages/python-check.scm (python-pytest-parawtf): New variable.
> ---
>  gnu/packages/python-check.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)
> 
> diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
> index 749902271b..ca6c2eaca8 100644
> --- a/gnu/packages/python-check.scm
> +++ b/gnu/packages/python-check.scm
> @@ -16,6 +16,7 @@
>  ;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
>  ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
>  ;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
> +;;; Copyright © 2022 jgart <jgart@dismail.de>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -2439,6 +2440,25 @@ (define-public python-sybil
>  provided for the main Python test runners.")
>      (license license:expat)))
>  
> +(define-public python-pytest-parawtf
> +  (package
> +    (name "python-pytest-parawtf")
> +    (version "1.0.2")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "pytest-parawtf" version))
> +              (sha256
> +               (base32
> +                "08s86hy58lvrd90cnayzydvac4slaflj0ph9yknakcc42anrm023"))))
> +    (build-system python-build-system)
    (arguments
     (list
       #:phases
       #~(modify-phases %standard-phases
           (replace 'check
             (lambda* (#:key tests? #:allow-other-keys)
               (when tests?
                 (invoke "pytest")))))))
> +    (propagated-inputs (list python-pytest))
> +    (home-page "https://bitbucket.org/flub/pytest-parawtf")
> +    (synopsis "Finally spell paramete?ri[sz]e correctly")
> +    (description 
> +"@code{python-pytest} uses one of four different spellings of
> +parametrize.  This plugin allows you to use all four.")
> +    (license license:expat)))
> +
>  (define-public python-pytest-httpx
>    (package
>      (name "python-pytest-httpx")
> -- 
> 2.38.1
> 
> 
> 
>
jgart Nov. 15, 2022, 2:51 p.m. UTC | #2
On Tue, 15 Nov 2022 11:16:06 +0200 Efraim Flashner <efraim@flashner.co.il> wrote:
> After enabling the test suite I found there were some failed tests.
> Also, the bitbucket source is gone, and it seems to have moved to
> GitHub.

Sorry for not updating this ticket status. I was meaning to send a new
patch for GitHub.

Thanks for the review. I'll send an update soon.
Ludovic Courtès Nov. 28, 2022, 9:59 p.m. UTC | #3
Hi,

jgart <jgart@dismail.de> skribis:

> On Tue, 15 Nov 2022 11:16:06 +0200 Efraim Flashner <efraim@flashner.co.il> wrote:
>> After enabling the test suite I found there were some failed tests.
>> Also, the bitbucket source is gone, and it seems to have moved to
>> GitHub.
>
> Sorry for not updating this ticket status. I was meaning to send a new
> patch for GitHub.
>
> Thanks for the review. I'll send an update soon.

Did you have a chance to look into it?

TIA,
Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 749902271b..ca6c2eaca8 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -16,6 +16,7 @@ 
 ;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
 ;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2439,6 +2440,25 @@  (define-public python-sybil
 provided for the main Python test runners.")
     (license license:expat)))
 
+(define-public python-pytest-parawtf
+  (package
+    (name "python-pytest-parawtf")
+    (version "1.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "pytest-parawtf" version))
+              (sha256
+               (base32
+                "08s86hy58lvrd90cnayzydvac4slaflj0ph9yknakcc42anrm023"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pytest))
+    (home-page "https://bitbucket.org/flub/pytest-parawtf")
+    (synopsis "Finally spell paramete?ri[sz]e correctly")
+    (description 
+"@code{python-pytest} uses one of four different spellings of
+parametrize.  This plugin allows you to use all four.")
+    (license license:expat)))
+
 (define-public python-pytest-httpx
   (package
     (name "python-pytest-httpx")