diff mbox series

[bug#59156] gnu: python-mdurl: Enable tests

Message ID 20221109195951.30629-1-sharlatanus@gmail.com
State New
Headers show
Series [bug#59156] gnu: python-mdurl: Enable tests | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Sharlatan Hellseher Nov. 9, 2022, 7:59 p.m. UTC
* gnu/packages/python-xyz.scm (python-mdurl): Enable tests.
  [source]: Use git checkout with tests.
  [build-system]: Use pyproject-build-system.
  [native-inputs]: Add python-pytest.
---
 gnu/packages/python-xyz.scm | 33 +++++++++++----------------------
 1 file changed, 11 insertions(+), 22 deletions(-)

Comments

Efraim Flashner Nov. 15, 2022, 10:31 a.m. UTC | #1
Thanks! Patch pushed.
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b2fb101409..9c7874e576 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -783,28 +783,17 @@  (define-public python-mdurl
   (package
     (name "python-mdurl")
     (version "0.1.2")
-    (source (origin
-              (method url-fetch)
-              (uri (pypi-uri "mdurl" version))
-              (sha256
-               (base32
-                "1fn1hy35h9grggwqax90zcb52inlfxrxsm27vlqqz8zfyllkshdv"))))
-    (build-system python-build-system)
-    (arguments
-     (list
-      #:tests? #f                       ;pypi source does not contain tests
-      #:phases
-      #~(modify-phases %standard-phases
-          (replace 'build
-            (lambda _ (invoke "flit" "build")))
-          (replace 'install
-            (lambda _
-              (for-each
-               (lambda (wheel)
-                 (invoke "python" "-m" "pip" "install"
-                         wheel (string-append "--prefix=" #$output)))
-               (find-files "dist" "\\.whl$")))))))
-    (native-inputs (list python-flit))
+    (source
+     (origin
+       (method git-fetch)   ; no tests data in PyPi package
+       (uri (git-reference
+             (url "https://github.com/executablebooks/mdurl")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0csc777q42jzv4zgdzxmwp8xqlb92ws1jvj09m2smh4klw67q5f3"))))
+    (build-system pyproject-build-system)
+    (native-inputs (list python-flit python-pytest))
     (home-page "https://github.com/executablebooks/mdurl")
     (synopsis "Markdown URL utilities")
     (description