diff mbox series

[bug#59154] gnu: Add python-xkcdpass.

Message ID 20221109183621.10818-1-antero@mailbox.org
State New
Headers show
Series [bug#59154] gnu: Add python-xkcdpass. | expand

Commit Message

Antero Mejr Nov. 9, 2022, 6:36 p.m. UTC
* gnu/packages/python-crypto.scm (python-xkcdpass): New variable.
---
 gnu/packages/python-crypto.scm | 32 ++++++++++++++++++++++++++++++++
 1 file changed, 32 insertions(+)

Comments

Lars-Dominik Braun Nov. 26, 2022, 8:57 a.m. UTC | #1
Hi,

pushed as afa5fa8d5b33e115745c720a1d06db0160d9d902 with some changes
(moved to password-utils.scm and installing manpage).

Thanks,
Lars
diff mbox series

Patch

diff --git a/gnu/packages/python-crypto.scm b/gnu/packages/python-crypto.scm
index c9eb226d8a..cc94a08ed1 100644
--- a/gnu/packages/python-crypto.scm
+++ b/gnu/packages/python-crypto.scm
@@ -1795,3 +1795,35 @@  (define-public python-zxcvbn
 in different situations.
 @end enumerate")
     (license license:expat)))
+
+(define-public python-xkcdpass
+  (package
+    (name "python-xkcdpass")
+    (version "1.19.3")
+    (home-page "https://github.com/redacted/XKCD-password-generator")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url home-page)
+                    (commit (string-append "xkcdpass-" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0xfrmx9k2vinlagv476rfcfdp41aix1ldy6qnzzx26n985gcyk7p"))))
+    (build-system python-build-system)
+    (synopsis
+     "Generate secure multiword passwords/passphrases, inspired by XKCD")
+    (description
+     "This package provides a flexible and scriptable password generator which
+generates strong passphrases, inspired by
+@url{https://xkcd.com/936/,XKCD 936}.")
+    (license (list license:bsd-3 ;code
+                   license:cc0 ;spanish, eff_large_de, french word lists
+                   license:cc-by-sa3.0 ;finnish, italian word list
+                   license:lgpl2.0 ;finnish word list
+                   license:eupl1.1 ;finnish word list
+                   license:gpl3 ;ger-anix word list
+                   license:cc-by-sa4.0 ;norwegian word list
+                   license:gpl2 ;portuguese word list
+                   license:lgpl2.1 ;portuguese word list
+                   license:mpl1.1)))) ;portuguese word list