diff mbox series

[bug#59126] gnu: go-github-com-zenhack-go-notmuch: Use UNGEXP-NATIVE with NOTMUCH-FIXTURES.

Message ID 20221108171958.4579-1-paren@disroot.org
State New
Headers show
Series [bug#59126] gnu: go-github-com-zenhack-go-notmuch: Use UNGEXP-NATIVE with NOTMUCH-FIXTURES. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

\( Nov. 8, 2022, 5:19 p.m. UTC
* gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch)
  [arguments]<#:phases>{'unpack-test-fixtures}: Use UNGEXP-NATIVE with
  NOTMUCH-FIXTURES.
---
 gnu/packages/golang.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 96ae718c516a289124a0b91ceeef78b20d187825

Comments

Christopher Baines Nov. 20, 2022, 11:28 a.m. UTC | #1
"( via Guix-patches" via <guix-patches@gnu.org> writes:

> * gnu/packages/golang.scm (go-github-com-zenhack-go-notmuch)
>   [arguments]<#:phases>{'unpack-test-fixtures}: Use UNGEXP-NATIVE with
>   NOTMUCH-FIXTURES.
> ---
>  gnu/packages/golang.scm | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
> index e52161228e..26b5048ed0 100644
> --- a/gnu/packages/golang.scm
> +++ b/gnu/packages/golang.scm
> @@ -10371,7 +10371,7 @@ (define-public go-github-com-zenhack-go-notmuch
>                            (lambda* (#:key inputs import-path
>                                      #:allow-other-keys)
>                              (invoke "tar" "xf"
> -                                    #$notmuch-fixtures "-C"
> +                                    #+notmuch-fixtures "-C"
>                                      (string-append "src/" import-path
>                                                     "/fixtures")))))))
>      (inputs (list notmuch))
>
> base-commit: 96ae718c516a289124a0b91ceeef78b20d187825

Hey,

I can guess at why you might be wanting to change this, but I'm
interested in what your actual reasoning is (and it's good if this is in
the commit message to)?

Thanks,

Chris
\( Nov. 20, 2022, 11:40 a.m. UTC | #2
On Sun Nov 20, 2022 at 11:28 AM GMT, Christopher Baines wrote:
> I can guess at why you might be wanting to change this, but I'm
> interested in what your actual reasoning is (and it's good if this is in
> the commit message to)?

Well, since NOTMUCH-FIXTURES is just an origin, it won't differ on
different systems. So, we don't need to cross-compile it, because a
non-cross-compiled version will work just as well. But Guix has no
way of knowing this, so if we use UNGEXP, it'll re-build the origin
unnecessarily. If we use UNGEXP-NATIVE, it'll just use the host's
NOTMUCH-FIXTURES.

    -- (
Christopher Baines Nov. 20, 2022, 12:09 p.m. UTC | #3
"(" <paren@disroot.org> writes:

> On Sun Nov 20, 2022 at 11:28 AM GMT, Christopher Baines wrote:
>> I can guess at why you might be wanting to change this, but I'm
>> interested in what your actual reasoning is (and it's good if this is in
>> the commit message to)?
>
> Well, since NOTMUCH-FIXTURES is just an origin, it won't differ on
> different systems. So, we don't need to cross-compile it, because a
> non-cross-compiled version will work just as well. But Guix has no
> way of knowing this, so if we use UNGEXP, it'll re-build the origin
> unnecessarily. If we use UNGEXP-NATIVE, it'll just use the host's
> NOTMUCH-FIXTURES.

Thanks. And yeah, given notmuch-fixtures is just an origin, maybe this
just does make sense without any extra explaination.

I've gone ahead and pushed this to master as
cfec9f055272feb6fca8c52ba92c8e7d831052ac.

Chris
\( Nov. 20, 2022, 12:12 p.m. UTC | #4
On Sun Nov 20, 2022 at 12:09 PM GMT, Christopher Baines wrote:
> I've gone ahead and pushed this to master as
> cfec9f055272feb6fca8c52ba92c8e7d831052ac.

Thanks!

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e52161228e..26b5048ed0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10371,7 +10371,7 @@  (define-public go-github-com-zenhack-go-notmuch
                           (lambda* (#:key inputs import-path
                                     #:allow-other-keys)
                             (invoke "tar" "xf"
-                                    #$notmuch-fixtures "-C"
+                                    #+notmuch-fixtures "-C"
                                     (string-append "src/" import-path
                                                    "/fixtures")))))))
     (inputs (list notmuch))