diff mbox series

[bug#59102,2/2] gnu: Add mogan.

Message ID 20221107105827.10327-2-all_but_last@163.com
State New
Headers show
Series [bug#59101,1/2] gnu: texmacs: Use G-expression. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Zhu Zihao Nov. 7, 2022, 10:58 a.m. UTC
* gnu/packages/text-editors.scm (mogan): New variable.
---
 gnu/packages/text-editors.scm | 34 ++++++++++++++++++++++++++++++++++
 1 file changed, 34 insertions(+)

Comments

Nicolas Goaziou Nov. 8, 2022, 9:01 p.m. UTC | #1
Hello,

Zhu Zihao <all_but_last@163.com> writes:

> * gnu/packages/text-editors.scm (mogan): New variable.

Thank you. I applied the first patch of the set. Some comments about
this one follow.

> +    (arguments
> +     (substitute-keyword-arguments (package-arguments texmacs)
> +       ((#:phases orig)
> +        #~(modify-phases #$orig
> +            ;; The non-deterministic compression issue is solved in Mogan.
> +            (delete 'gzip-flags)))))

Unlike TeXmacs, Mogan ships with tests. Could you also run them?

> +    (synopsis "Structural editor delivered by Xmacs Labs")

I don't think the ads is warranted here. Maybe "Scientific text editor"
is better.

> +    (description
> +     "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
> +make everyone to enjoy it fluently and develop new feature for everyone to learn
> +and create science and technology.")

This description is not very descriptive. I don't have any good idea,
the repository is not very helpful for that matter. At a minimum,
I suggest to remove "created by Xmacs Labs" and separate sentences with
two spaces. The second should also be replaced.

> +    (home-page "https://gitee.com/XmacsLabs/mogan")))

Could you move home-page above synopsis?

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index ca502994c5..cddbf06c90 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -59,6 +59,7 @@  (define-module (gnu packages text-editors)
   #:use-module (gnu packages code)
   #:use-module (gnu packages cpp)
   #:use-module (gnu packages crates-io)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages datastructures)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
@@ -895,6 +896,39 @@  (define-public texmacs
     (license license:gpl3+)
     (home-page "https://www.texmacs.org/tmweb/home/welcome.en.html")))
 
+(define-public mogan
+  (package
+    (inherit texmacs)
+    (name "mogan")
+    (version "1.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/XmacsLabs/mogan")
+             (commit (string-append "v" version))))
+       (sha256
+        (base32 "04wz6xmimjv2l6baxgzm8vyq5grg102m3l4wq8i6bglv529yp4ff"))))
+    (inputs
+     (modify-inputs (package-inputs texmacs)
+       ;; Replaced by S7 scheme
+       ;; TODO: Maybe unbundle S7
+       (delete "guile")
+       (prepend curl)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments texmacs)
+       ((#:phases orig)
+        #~(modify-phases #$orig
+            ;; The non-deterministic compression issue is solved in Mogan.
+            (delete 'gzip-flags)))))
+    (synopsis "Structural editor delivered by Xmacs Labs")
+    (description
+     "Mogan is a fork of GNU TeXmacs created by Xmacs Labs. Its goal is
+make everyone to enjoy it fluently and develop new feature for everyone to learn
+and create science and technology.")
+    (license license:gpl3+)
+    (home-page "https://gitee.com/XmacsLabs/mogan")))
+
 (define-public textpieces
   (package
     (name "textpieces")