diff mbox series

[bug#58792,v3,2/2] gnu: python-virtualenv: Update to 20.16.5.

Message ID 20221105112435.20540-2-tanguy@bioneland.org
State New
Headers show
Series [bug#58792,v3,1/2] gnu: python-filelock: Update to 3.8.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Tanguy LE CARROUR Nov. 5, 2022, 11:24 a.m. UTC
* gnu/packages/python-xyz.scm (python-virtualenv): Update to 20.16.5.
[arguments]<#:phases>: Add phase compatibility-fixes.
[propagated-inputs]: Add python-platformdirs.
---
 gnu/packages/python-xyz.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 83e86b21fd..d6efd92bcf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4149,19 +4149,26 @@  (define-public python-vine
 (define-public python-virtualenv
   (package
     (name "python-virtualenv")
-    (version "20.3.1")
+    (version "20.16.5")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "virtualenv" version))
        (sha256
         (base32
-         "1nbhnpzswcf3lmzn5xabmfdd7ki8r2w2i37y6wml54di6qi1l48c"))))
+         "1nl09v092ap469krvgl5x9r78v99xy1k7fkp36imxp2gk6ws2zi2"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'compatibility-fixes
+           (lambda _
+             ;; We have an outdated version of distlib
+             (substitute* "setup.cfg" (("0.3.5") "0.3.1")))))))
     (native-inputs
      (list python-mock python-pytest python-setuptools-scm))
     (propagated-inputs
-     (list python-appdirs python-distlib python-filelock python-six))
+     (list python-appdirs python-distlib python-filelock python-platformdirs python-six))
     (home-page "https://virtualenv.pypa.io/")
     (synopsis "Virtual Python environment builder")
     (description