diff mbox series

[bug#59033] etc: teams: Add pyproject-build-system to python scope.

Message ID 20221105013449.22093-1-jgart@dismail.de
State New
Headers show
Series [bug#59033] etc: teams: Add pyproject-build-system to python scope. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 5, 2022, 1:34 a.m. UTC
* etc/teams.scm.in (python): Add guix/build/pyproject-build-system.scm to
 python team's scope.
---
 etc/teams.scm.in | 1 +
 1 file changed, 1 insertion(+)

Comments

\( Nov. 5, 2022, 8:22 a.m. UTC | #1
Heya,

On Sat Nov 5, 2022 at 1:34 AM GMT, jgart via Guix-patches via wrote:
> +              "guix/build/pyproject-build-system.scm"
>                "guix/build/python-build-system.scm"
>                "guix/build-system/python.scm"

You should also add ``guix/build-system/pyproject.scm'' here ;)

    -- (
Christopher Baines Nov. 6, 2022, 3:10 p.m. UTC | #2
"( via Guix-patches" via <guix-patches@gnu.org> writes:

> Heya,
>
> On Sat Nov 5, 2022 at 1:34 AM GMT, jgart via Guix-patches via wrote:
>> +              "guix/build/pyproject-build-system.scm"
>>                "guix/build/python-build-system.scm"
>>                "guix/build-system/python.scm"
>
> You should also add ``guix/build-system/pyproject.scm'' here ;)

Since that makes sense to me, I've gone ahead and pushed this with the
above change.

Hope you don't mind,

Chris
diff mbox series

Patch

diff --git a/etc/teams.scm.in b/etc/teams.scm.in
index 12f83eb76d..87a88e595b 100644
--- a/etc/teams.scm.in
+++ b/etc/teams.scm.in
@@ -100,6 +100,7 @@  (define-team python
               (make-regexp "^gnu/packages/python(-.+|)\\.scm$")
               "gnu/packages/sphinx.scm"
               "gnu/packages/tryton.scm"
+              "guix/build/pyproject-build-system.scm"
               "guix/build/python-build-system.scm"
               "guix/build-system/python.scm"
               "guix/import/pypi.scm"