diff mbox series

[bug#58997,v3] gnu: jo: Update to 1.9.

Message ID 20221103190943.17951-1-jgart@dismail.de
State New
Headers show
Series [bug#58997,v3] gnu: jo: Update to 1.9. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 3, 2022, 7:09 p.m. UTC
* gnu/packages/web.scm (jo): Update to 1.9.

hi, ignore v2
---
 gnu/packages/web.scm | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

Comments

Tobias Geerinckx-Rice Nov. 3, 2022, 7:24 p.m. UTC | #1
jgart via Guix-patches via 写道:
> hi, ignore v2

But it's identical.

Was v3 perhaps supposed to include the changelog entry for 
[description]?

Kind regards,

T G-R
jgart Nov. 3, 2022, 7:51 p.m. UTC | #2
On Thu, 03 Nov 2022 20:24:02 +0100 Tobias Geerinckx-Rice <me@tobias.gr> wrote:
> jgart via Guix-patches via 写道:
> > hi, ignore v2
> 
> But it's identical.
> 
> Was v3 perhaps supposed to include the changelog entry for 
> [description]?

v3 just had a better commit message ;()
Tobias Geerinckx-Rice Nov. 3, 2022, 7:56 p.m. UTC | #3
Again: was v3 perhaps supposed to include the changelog entry for
[description]?

Kind regards,

T G-R
Tobias Geerinckx-Rice Nov. 3, 2022, 8:14 p.m. UTC | #4
Tobias Geerinckx-Rice via Guix-patches via 写道:
> Again: was v3 perhaps supposed to include the changelog entry 
> for
> [description]?

Bah, never mind: I can't imagine what else it could have been :-)

Pushed as bbac6c52480dc8572b74eb6235bdf55c1cf9842b, with @code{} → 
the more appropriate @command{}.  Thanks!

Side note: please add notes to reviewers & anything else that 
isn't part of the commit message proper under the ‘---’ produced 
by Git:

…

* gnu/packages/web.scm (jo): Update to 1.9.

---

hi, ignore v1

 gnu/packages/web.scm | 6 +++---
 …

Kind regards,

T G-R
jgart Nov. 3, 2022, 8:39 p.m. UTC | #5
On Thu, 03 Nov 2022 20:56:48 +0100 Tobias Geerinckx-Rice <me@tobias.gr> wrote:
> Again: was v3 perhaps supposed to include the changelog entry for
> [description]?

Oh yes, it was. Sorry, misread
diff mbox series

Patch

diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 06c633812b..bf94c7def7 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -6240,18 +6240,18 @@  (define-public python-httpretty
 (define-public jo
   (package
     (name "jo")
-    (version "1.7")
+    (version "1.9")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://github.com/jpmens/jo/releases/download/"
                            version "/jo-" version ".tar.gz"))
        (sha256
-        (base32 "0ml6ismigsflaa2dqg44ccljcl8f4jiipxvyq5lszfsh0qph7hvl"))))
+        (base32 "17y73657z5v792ik3plcvk9f5g5h2yawv6afahhkq42159pwv581"))))
     (build-system gnu-build-system)
     (home-page "https://github.com/jpmens/jo")
     (synopsis "Output JSON from a shell")
-    (description "jo is a command-line utility to create JSON objects or
+    (description "@code{jo} is a command-line utility to create JSON objects or
 arrays.  It creates a JSON string on stdout from words provided as
 command-line arguments or read from stdin.")
     (license (list license:gpl2+