diff mbox series

[bug#58696,v2] gnu: Add python-eris.

Message ID 20221103173043.11037-1-jgart@dismail.de
State New
Headers show
Series [bug#58696,v2] gnu: Add python-eris. | expand

Commit Message

jgart Nov. 3, 2022, 5:30 p.m. UTC
* gnu/packages/python-xyz.scm (python-eris): New variable.

Hi, thanks for the review. Here's an updated patch with your requests.
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Christopher Baines Nov. 3, 2022, 5:55 p.m. UTC | #1
jgart <jgart@dismail.de> writes:

> * gnu/packages/python-xyz.scm (python-eris): New variable.
>
> Hi, thanks for the review. Here's an updated patch with your requests.

Great, pushed to master as 9560932ce04bfecdfefc5fdb8699fa1f64887286.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 04cc2a363b..342e9c0a34 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31225,6 +31225,25 @@  (define-public python-lief
 and abstract ELF, PE and MachO formats.")
     (license license:asl2.0)))
 
+(define-public python-eris
+  (package
+    (name "python-eris")
+    (version "0.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "eris" version))
+              (sha256
+               (base32
+                "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pycryptodome))
+    (home-page "https://codeberg.org/eris/python-eris")
+    (synopsis "Python implementation of ERIS")
+    (description
+"Python implementation of the @acronym{ERIS, Encoding for Robust Immutable
+Storage}.")
+    (license license:lgpl3+)))
+
 (define-public shrinkwrap
   (package
     (name "shrinkwrap")