diff mbox series

[bug#58963] gnu: python-funcparserlib: Enable tests.

Message ID 20221102070346.12715-1-jgart@dismail.de
State New
Headers show
Series [bug#58963] gnu: python-funcparserlib: Enable tests. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 2, 2022, 7:03 a.m. UTC
* gnu/packages/python-xyz.scm (python-funcparserlib): Enable tests.
[origin]: Use GitHub since it includes the tests unlike PyPi.
[build-system]: Use pyproject-build-system.
[arguments]: Run tests.
[native-inputs]: Add python-poetry-core.
---
 gnu/packages/python-xyz.scm | 25 ++++++++++++++++++-------
 1 file changed, 18 insertions(+), 7 deletions(-)

Comments

Christopher Baines Nov. 5, 2022, 11 a.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-xyz.scm (python-funcparserlib): Enable tests.
> [origin]: Use GitHub since it includes the tests unlike PyPi.
> [build-system]: Use pyproject-build-system.
> [arguments]: Run tests.
> [native-inputs]: Add python-poetry-core.
> ---
>  gnu/packages/python-xyz.scm | 25 ++++++++++++++++++-------
>  1 file changed, 18 insertions(+), 7 deletions(-)

Looks good to me, I've pushed to master as
f91713e71b6bc1222c8f5b218dede3dc7e670a3c.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1c2f9d7b73..eb5b74c993 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -25303,14 +25303,25 @@  (define-public python-funcparserlib
     (name "python-funcparserlib")
     (version "1.0.0")
     (source
-     (origin
-       (method url-fetch)
-       (uri (pypi-uri "funcparserlib" version))
-       (sha256
-        (base32 "0swbqf53x7lfnczvi566s1g3nkf5mfrxz7sbpyymricz57a3vlvx"))))
-    (build-system python-build-system)
+      (origin
+        ;; Source tarball on PyPi lacks tests.
+        (method git-fetch)
+        (uri (git-reference
+              (url "https://github.com/vlasovskikh/funcparserlib")
+              (commit version)))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "00pswdys5c4hpqpvfcy5zqv30gyjvjvagi12811jizw57hxrm1cs"))))
+    (build-system pyproject-build-system)
     (arguments
-     `(#:tests? #f))              ; no tests in PyPI and no setup.py in GitHub
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (when tests?
+               (invoke "python" "-m" "unittest" "discover" "-v")))))))
+    ;; ModuleNotFoundError: No module named 'poetry'
+    (native-inputs (list python-poetry-core))
     (home-page "https://github.com/vlasovskikh/funcparserlib")
     (synopsis
      "Recursive descent parsing library based on functional combinators")