diff mbox series

[bug#58936,2/2] gnu: Add the-way.

Message ID 20221101014611.30081-2-jgart@dismail.de
State New
Headers show
Series [bug#58936,1/2] gnu: Add crates for the-way. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

jgart Nov. 1, 2022, 1:46 a.m. UTC
* gnu/packages/rust-apps.scm (the-way): New variable.
---
 gnu/packages/rust-apps.scm | 50 ++++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index 693489264d..0935c037c6 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2062,3 +2062,53 @@  (define-public zoxide
 track of the directories you use most frequently, and uses a ranking algorithm
 to navigate to the best match.")
     (license license:expat)))
+
+(define-public the-way
+  (package
+    (name "the-way")
+    (version "0.18.0")
+    (source (origin
+              (method url-fetch)
+              (uri (crate-uri "the-way" version))
+              (file-name (string-append name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "19pipvr35i4lfpk01f8gfjpp9rwr8p2qbmgyqgclr1lir2aa8slq"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs (("rust-bincode" ,rust-bincode-1)
+                       ("rust-chrono" ,rust-chrono-0.4)
+                       ("rust-chrono-english" ,rust-chrono-english-0.1)
+                       ("rust-clap" ,rust-clap-3)
+                       ("rust-clap-complete" ,rust-clap-complete-3)
+                       ("rust-color-eyre" ,rust-color-eyre-0.6)
+                       ("rust-confy" ,rust-confy-0.4)
+                       ("rust-dialoguer" ,rust-dialoguer-0.10)
+                       ("rust-directories-next" ,rust-directories-next-1)
+                       ("rust-eyre" ,rust-eyre-0.6)
+                       ("rust-grep-cli" ,rust-grep-cli-0.1)
+                       ("rust-hex" ,rust-hex-0.4)
+                       ("rust-indicatif" ,rust-indicatif-0.17)
+                       ("rust-regex" ,rust-regex-1)
+                       ("rust-serde" ,rust-serde-1)
+                       ("rust-serde-derive" ,rust-serde-derive-1)
+                       ("rust-serde-json" ,rust-serde-json-1)
+                       ("rust-serde-yaml" ,rust-serde-yaml-0.9)
+                       ("rust-skim" ,rust-skim-0.9)
+                       ("rust-sled" ,rust-sled-0.34)
+                       ("rust-strum" ,rust-strum-0.24)
+                       ("rust-strum-macros" ,rust-strum-macros-0.24)
+                       ("rust-syntect" ,rust-syntect-5)
+                       ("rust-termcolor" ,rust-termcolor-1)
+                       ("rust-thiserror" ,rust-thiserror-1)
+                       ("rust-ureq" ,rust-ureq-2))
+       #:cargo-development-inputs (("rust-assert-cmd" ,rust-assert-cmd-2)
+                                   ("rust-clipboard" ,rust-clipboard-0.5)
+                                   ("rust-expectrl" ,rust-expectrl-0.5)
+                                   ("rust-predicates" ,rust-predicates-2)
+                                   ("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/out-of-cheese-error/the-way")
+    (synopsis "Code snippets manager for your terminal")
+    (description
+     "This package provides a code snippets manager for your terminal.")
+    (license license:expat)))