diff mbox series

[bug#58898,v3] gnu: Add carp.

Message ID 20221030162217.32504-1-jgart@dismail.de
State New
Headers show
Series [bug#58898,v3] gnu: Add carp. | expand

Commit Message

jgart Oct. 30, 2022, 4:22 p.m. UTC
* gnu/packages/lisp.scm (carp): New variable.

v3: oops silly me out was being used...
---
 gnu/packages/lisp.scm | 56 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 4899943ba8..763219fff6 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -55,6 +55,7 @@  (define-module (gnu packages lisp)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system ant)
   #:use-module (guix build-system asdf)
+  #:use-module (guix build-system haskell)
   #:use-module (guix build-system trivial)
   #:use-module (gnu packages admin)
   #:use-module (gnu packages base)
@@ -71,10 +72,14 @@  (define-module (gnu packages lisp)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages groff)
+  #:use-module (gnu packages haskell-check)
+  #:use-module (gnu packages haskell-web)
+  #:use-module (gnu packages haskell-xyz)
   #:use-module (gnu packages libffcall)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages libsigsegv)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages llvm)
   #:use-module (gnu packages m4)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages multiprecision)
@@ -1268,6 +1273,57 @@  (define-public janet
 assembler, PEG) is less than 1MB.")
     (license license:expat)))
 
+(define-public carp
+  (package
+    (name "carp")
+    (version "0.5.5")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/carp-lang/Carp")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "14jdnv0ljqvpr9ych1plfw7hp5q57a8j1bv8h3v345x06z783d07"))))
+    (build-system haskell-build-system)
+    (arguments
+      `(#:phases
+         (modify-phases %standard-phases
+           ;; Carp looks inside the sources checkout to know where to
+           ;; find its core libraries and other files.
+           ;; Carp emits C code and tries to compile it with an external
+           ;; C compiler. On Linux it defaults to Clang.
+           (add-after 'install 'set-carp-dir-and-path
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (let ((sources (assoc-ref inputs "source"))
+                     (clang (assoc-ref inputs "clang")))
+                 (wrap-program (string-append out "/bin/carp")
+                   `("CARP_DIR" = (,sources))
+                   `("PATH" = (,(string-append clang "/bin"))))
+                 (wrap-program (string-append out "/bin/carp-header-parse")
+                   `("CARP_DIR" = (,sources))
+                   `("PATH" = (,(string-append clang "/bin"))))))))))
+    (native-inputs (list ghc-hunit))
+    (inputs (list bash-minimal
+                  clang
+                  ghc-blaze-markup
+                  ghc-blaze-html
+                  ghc-split
+                  ghc-ansi-terminal
+                  ghc-cmark
+                  ghc-edit-distance
+                  ghc-hashable
+                  ghc-open-browser
+                  ghc-optparse-applicative))
+    (home-page "https://carp-lang.org/")
+    (synopsis "Statically typed Lisp without a garbage collector")
+    (description
+"@code{carp} is a programming language designed to work well for
+interactive and performance sensitive use cases like games, sound
+synthesis and visualizations.")
+    (license license:asl2.0)))
+
 (define-public lisp-repl-core-dumper
   (package
     (name "lisp-repl-core-dumper")