diff mbox series

[bug#58849] gnu: wesnoth: Update to 1.16.6.

Message ID 20221028235758.19931-1-paren@disroot.org
State New
Headers show
Series [bug#58849] gnu: wesnoth: Update to 1.16.6. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

\( Oct. 28, 2022, 11:57 p.m. UTC
* gnu/packages/games.scm (wesnoth): Update to 1.16.6.
---
 gnu/packages/games.scm | 22 +++++++++++-----------
 1 file changed, 11 insertions(+), 11 deletions(-)


base-commit: 0a604c16b34f8147bf18e065e8b30d8d23cd8998

Comments

Nicolas Goaziou Oct. 29, 2022, 9:55 p.m. UTC | #1
Hello,

"( via Guix-patches" via <guix-patches@gnu.org> writes:

> * gnu/packages/games.scm (wesnoth): Update to 1.16.6.

Applied. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4f82bf710a..56d4ad2d87 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4293,22 +4293,19 @@  (define-public gnujump
 (define-public wesnoth
   (package
     (name "wesnoth")
-    (version "1.16.5")
+    (version "1.16.6")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "mirror://sourceforge/wesnoth/wesnoth-"
-                                  (version-major+minor version)
-                                  "/wesnoth-" version "/"
-                                  "wesnoth-" version ".tar.bz2"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/wesnoth/wesnoth")
+                    (commit version)))
+              (file-name (string-append name "-" version ".tar.bz2"))
               (sha256
                (base32
-                "02pzijbmkgcb8hc4l3f4r3r3mxqda936dp488i9sd9d4m3xdzimh"))))
+                "0hfvxmdnwn86w254blbjacia342j47rhhahm6ca79la9d04rlz3m"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f))                    ;no check target
-    (native-inputs
-     `(("gettext" ,gettext-minimal)
-       ("pkg-config" ,pkg-config)))
+     (list #:tests? #f)) ;no test target
     (inputs
      (list boost
            dbus
@@ -4317,6 +4314,9 @@  (define-public wesnoth
            openssl
            pango
            (sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf))))
+    (native-inputs
+     (list gettext-minimal
+           pkg-config))
     (home-page "https://www.wesnoth.org/")
     (synopsis "Turn-based strategy game")
     (description