diff mbox series

[bug#58394,4/4] gnu: libcxx+libcxxabi: Use G-expressions.

Message ID 20221027083330.960-4-all_but_last@163.com
State New
Headers show
Series [bug#58394] : gnu: libcxx: Update to 14.0.6. | expand

Commit Message

Zhu Zihao Oct. 27, 2022, 8:33 a.m. UTC
* gnu/packages/llvm.scm (libcxx+libcxxabi-6)[arguments]: Use G-expressions.
<#:configure-flags>: Use "this-package-native-input".
---
 gnu/packages/llvm.scm | 44 ++++++++++++++++++++++---------------------
 1 file changed, 23 insertions(+), 21 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 17c51ea6bb..324149116b 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -1677,27 +1677,29 @@  (define-public libcxx+libcxxabi-6
     (name "libcxx+libcxxabi")
     (version (package-version libcxx-6))
     (arguments
-     `(#:configure-flags
-       (list "-DLIBCXX_CXX_ABI=libcxxabi"
-             (string-append "-DLIBCXX_CXX_ABI_INCLUDE_PATHS="
-                            (assoc-ref %build-inputs "libcxxabi")
-                            "/include"))
-       #:phases
-       (modify-phases (@ (guix build cmake-build-system) %standard-phases)
-         (add-after 'set-paths 'adjust-CPLUS_INCLUDE_PATH
-           (lambda* (#:key inputs #:allow-other-keys)
-             (let ((gcc (assoc-ref inputs  "gcc")))
-               ;; Hide GCC's C++ headers so that they do not interfere with
-               ;; the ones we are attempting to build.
-               (setenv "CPLUS_INCLUDE_PATH"
-                       (string-join
-                        (delete (string-append gcc "/include/c++")
-                                (string-split (getenv "CPLUS_INCLUDE_PATH")
-                                              #\:))
-                        ":"))
-               (format #true
-                       "environment variable `CPLUS_INCLUDE_PATH' changed to ~a~%"
-                       (getenv "CPLUS_INCLUDE_PATH"))))))))
+     (list
+      #:configure-flags
+      #~(list "-DLIBCXX_CXX_ABI=libcxxabi"
+              (string-append "-DLIBCXX_CXX_ABI_INCLUDE_PATHS="
+                             #$(this-package-native-input "libcxxabi")
+                             "/include"))
+      #:phases
+      #~(modify-phases (@ (guix build cmake-build-system) %standard-phases)
+          (add-after 'set-paths 'adjust-CPLUS_INCLUDE_PATH
+            (lambda* (#:key inputs #:allow-other-keys)
+              (let ((gcc (assoc-ref inputs  "gcc")))
+                ;; Hide GCC's C++ headers so that they do not interfere with
+                ;; the ones we are attempting to build.
+                (setenv "CPLUS_INCLUDE_PATH"
+                        (string-join
+                         (delete (string-append gcc "/include/c++")
+                                 (string-split (getenv "CPLUS_INCLUDE_PATH")
+                                               #\:))
+                         ":"))
+                (format
+                 #true
+                 "environment variable `CPLUS_INCLUDE_PATH' changed to ~a~%"
+                 (getenv "CPLUS_INCLUDE_PATH"))))))))
     (native-inputs
      (list clang-6 llvm-6 libcxxabi-6))))