diff mbox series

[bug#58792] gnu: python-filelock: Update to 3.8.0.

Message ID 20221026071312.4635-1-tanguy@bioneland.org
State New
Headers show
Series [bug#58792] gnu: python-filelock: Update to 3.8.0. | expand

Commit Message

Tanguy LE CARROUR Oct. 26, 2022, 7:13 a.m. UTC
Hi Guix,

This patch is trivial, but it triggers 5,000+ package rebuilds.
I need it in order to upgrade `python-virtualenv` (I'm still working on it)
… which I need to upgrade `poetry`.

Regards,


* gnu/packages/python-xyz.scm (python-filelock): Update to 3.8.0.
---
 gnu/packages/python-xyz.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Tanguy LE CARROUR Oct. 26, 2022, 8:03 a.m. UTC | #1
Hi Guix,

Contrary to what I said, this patch might not be trivial!

The resulting package exposes version 0.0.0, which seems to break every
package that depends on it!
The issue has been reported upstream [1][]. The solution would be to use
a different build system.

[1]: https://github.com/tox-dev/py-filelock/issues/133)

I'm working on it…
Tanguy LE CARROUR Feb. 29, 2024, 8:20 a.m. UTC | #2
Hi Guix,

I’m closing this old bug, because:

- the patch set probably does not apply anymore;
- even if the affected packages still need to be updated,
  I don’t need them anymore as —long story short—,
  I’m not trying to make Poetry available in Guix.

Regards,
Tanguy LE CARROUR Feb. 29, 2024, 8:32 a.m. UTC | #3
Hi Guix,

I’m closing this old bug, because:

- the patch set probably does not apply anymore;
- even if the affected packages still need to be updated,
  I don’t need them anymore as —long story short—,
  I’m not trying to make Poetry available in Guix.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 08a33061a9..eacb54d406 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1978,14 +1978,14 @@  (define-public python-fb-re2
 (define-public python-filelock
   (package
     (name "python-filelock")
-    (version "3.0.12")
+    (version "3.8.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "filelock" version))
        (sha256
         (base32
-         "0ngzlvb5j8gqs2nxlp2b0jhzii792h66wsn694qm8kqixr225n0q"))))
+         "1p2f1il288abcrjx002w25dzl9jd1392cfminv2rh8bgcsm7qi2m"))))
     (build-system python-build-system)
     (home-page
      "https://github.com/benediktschmitt/py-filelock")