diff mbox series

[bug#58773] gnu: gst-plugins-bad: Skip elements/camerabin test on some systems.

Message ID 20221025104938.3474-1-mail@cbaines.net
State New
Headers show
Series [bug#58773] gnu: gst-plugins-bad: Skip elements/camerabin test on some systems. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue

Commit Message

Christopher Baines Oct. 25, 2022, 10:49 a.m. UTC
It seems to frequently fail on i686-linux and aarch64-linux.

* gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
elements/camerabin test on i686-linux and aarch64-linux.
---
 gnu/packages/gstreamer.scm | 8 ++++++++
 1 file changed, 8 insertions(+)

Comments

Liliana Marie Prikler Oct. 25, 2022, 7:10 p.m. UTC | #1
Am Dienstag, dem 25.10.2022 um 11:49 +0100 schrieb Christopher Baines:
> It seems to frequently fail on i686-linux and aarch64-linux.
> 
> * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
> elements/camerabin test on i686-linux and aarch64-linux.
> ---
>  gnu/packages/gstreamer.scm | 8 ++++++++
>  1 file changed, 8 insertions(+)
> 
> diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
> index a92588a9e2..c211816bf8 100644
> --- a/gnu/packages/gstreamer.scm
> +++ b/gnu/packages/gstreamer.scm
> @@ -791,6 +791,14 @@ (define-public gst-plugins-bad
>                    ;; FIXME: Why is this failing.
>                    ((".*elements/dash_mpd\\.c.*") "")
>  
> +                  #$@(if (member (%current-system)
> +                                 '("i686-linux" "aarch64-linux"))
> +                         ;; This test is flaky:
> +                         ;;
> https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
> +                         `((("'elements/camerabin\\.c'\\]\\],")
> +                            "'elements/camerabin.c'], true, ],"))
> +                         '())
> +
>                    ;; These tests are flaky and occasionally time
> out:
>                    ;;
> https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
You might want to use ", see" instead of the colon and wrap the link in
angular brackets, i.e. <https://...>.  Don't forget to end the sentence
with a period.
>                    ((".*elements/curlhttpsrc\\.c.*") "")
Otherwise LGTM
Liliana Marie Prikler Nov. 26, 2022, 12:49 p.m. UTC | #2
Am Dienstag, dem 25.10.2022 um 21:10 +0200 schrieb Liliana Marie
Prikler:
> Am Dienstag, dem 25.10.2022 um 11:49 +0100 schrieb Christopher
> Baines:
> > It seems to frequently fail on i686-linux and aarch64-linux.
> > 
> > * gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Skip the
> > elements/camerabin test on i686-linux and aarch64-linux.
> > ---
> >  gnu/packages/gstreamer.scm | 8 ++++++++
> >  1 file changed, 8 insertions(+)
> > 
> > diff --git a/gnu/packages/gstreamer.scm
> > b/gnu/packages/gstreamer.scm
> > index a92588a9e2..c211816bf8 100644
> > --- a/gnu/packages/gstreamer.scm
> > +++ b/gnu/packages/gstreamer.scm
> > @@ -791,6 +791,14 @@ (define-public gst-plugins-bad
> >                    ;; FIXME: Why is this failing.
> >                    ((".*elements/dash_mpd\\.c.*") "")
> >  
> > +                  #$@(if (member (%current-system)
> > +                                 '("i686-linux" "aarch64-linux"))
> > +                         ;; This test is flaky:
> > +                         ;;
> > https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
> > +                         `((("'elements/camerabin\\.c'\\]\\],")
> > +                            "'elements/camerabin.c'], true, ],"))
> > +                         '())
> > +
> >                    ;; These tests are flaky and occasionally time
> > out:
> >                    ;;
> > https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
> You might want to use ", see" instead of the colon and wrap the link
> in angular brackets, i.e. <https://...>.  Don't forget to end the
> sentence with a period.
> 
Turns out angular brackets aren't in vogue in this file.

Pushed with a slightly altered comment.
diff mbox series

Patch

diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index a92588a9e2..c211816bf8 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -791,6 +791,14 @@  (define-public gst-plugins-bad
                   ;; FIXME: Why is this failing.
                   ((".*elements/dash_mpd\\.c.*") "")
 
+                  #$@(if (member (%current-system)
+                                 '("i686-linux" "aarch64-linux"))
+                         ;; This test is flaky:
+                         ;; https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/1244
+                         `((("'elements/camerabin\\.c'\\]\\],")
+                            "'elements/camerabin.c'], true, ],"))
+                         '())
+
                   ;; These tests are flaky and occasionally time out:
                   ;; https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/issues/932
                   ((".*elements/curlhttpsrc\\.c.*") "")