diff mbox series

[bug#58696] gnu: Add python-eris.

Message ID 20221022005529.30026-1-jgart@dismail.de
State New
Headers show
Series [bug#58696] gnu: Add python-eris. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 22, 2022, 12:55 a.m. UTC
* gnu/packages/python-xyz.scm (python-eris): New variable.

Codeberg mirror seems to get stuck on a request.

PyPi doesn't include tests.

WDYT
---
 gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
 1 file changed, 19 insertions(+)

Comments

Christopher Baines Nov. 3, 2022, 4:22 p.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/python-xyz.scm (python-eris): New variable.
>
> Codeberg mirror seems to get stuck on a request.
>
> PyPi doesn't include tests.
>
> WDYT
> ---
>  gnu/packages/python-xyz.scm | 19 +++++++++++++++++++
>  1 file changed, 19 insertions(+)

Hi jgart,

This seems OK to me, although the license needs checking as I mention
below.

> diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
> index 706de291c9..e90dede7fa 100644
> --- a/gnu/packages/python-xyz.scm
> +++ b/gnu/packages/python-xyz.scm
> @@ -31142,6 +31142,25 @@ (define-public python-lief
>  and abstract ELF, PE and MachO formats.")
>      (license license:asl2.0)))
>  
> +(define-public python-eris
> +  (package
> +    (name "python-eris")
> +    (version "0.0.2")
> +    (source (origin
> +              (method url-fetch)
> +              (uri (pypi-uri "eris" version))
> +              (sha256
> +               (base32
> +                "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
> +    (build-system python-build-system)
> +    (propagated-inputs (list python-pycryptodome))
> +    (home-page "https://codeberg.org/eris/python-eris")
> +    (synopsis "Python implementation of ERIS")
> +    (description
> +"Python implementation of the Encoding for Robust Immutable Storage
> +(ERIS)."

There's a @acronym thing you could use here.

> +    (license license:gpl2+)))

Can you check this? It seems different to me.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 706de291c9..e90dede7fa 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31142,6 +31142,25 @@  (define-public python-lief
 and abstract ELF, PE and MachO formats.")
     (license license:asl2.0)))
 
+(define-public python-eris
+  (package
+    (name "python-eris")
+    (version "0.0.2")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "eris" version))
+              (sha256
+               (base32
+                "16wbmahmfzdzrsjbn8jzi79vhghrzvvlcgnym20q0v3p3i4x47pq"))))
+    (build-system python-build-system)
+    (propagated-inputs (list python-pycryptodome))
+    (home-page "https://codeberg.org/eris/python-eris")
+    (synopsis "Python implementation of ERIS")
+    (description
+"Python implementation of the Encoding for Robust Immutable Storage
+(ERIS).")
+    (license license:gpl2+)))
+
 (define-public shrinkwrap
   (package
     (name "shrinkwrap")