diff mbox series

[bug#58616] gnu: Add emacs-org-cliplink.

Message ID 20221018235724.17839-1-jgart@dismail.de
State Accepted
Headers show
Series [bug#58616] gnu: Add emacs-org-cliplink. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 18, 2022, 11:57 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-org-cliplink): New variable.
---
 gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
 1 file changed, 35 insertions(+)

Comments

Nicolas Goaziou Oct. 21, 2022, 8:02 a.m. UTC | #1
Hello,

jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-org-cliplink): New variable.

Thank you. Applied with the following changes.

> +(define-public emacs-org-cliplink
> +  (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
> +        (revision "0"))
> +    (package
> +      (name "emacs-org-cliplink")
> +      (version (git-version "20201126" revision commit))

Base version is actually "0.2", according to Version keyword in the main
file.

> +      (arguments
> +        (list

I also activated tests.

> +         #:phases
> +         #~(modify-phases %standard-phases
> +             (add-after 'unpack 'patch-geiser-racket-binary

The name of the phase looks like a copy-pasta typo. I overlooked it.
I'll fix it in a subsequent commit.

> +               (lambda* (#:key inputs #:allow-other-keys)
> +                 (substitute* "org-cliplink-transport.el"
> +                   (("curl\")")
> +                    (string-append (search-input-file inputs "bin/curl") "\")"))))))))
> +      (inputs (list curl))
> +      (home-page "https://github.com/rexim/org-cliplink/")
> +      (synopsis "Insert org-mode links from the clipboard")

org-mode -> Org mode

> +      (description
> +"@code{emacs-org-cliplink} provides a simple command that takes a URL

emacs-org-cliplink is the internal name of the Guix variable bound to
the package definition. The project is actually org-cliplink or (as
a matter of taste) Org Cliplink.

> +from the clipboard and inserts an org-mode link with a title of a page

Again : org-mode -> Org mode.

Regards,
jgart Oct. 21, 2022, 4:33 p.m. UTC | #2
On Fri, 21 Oct 2022 10:02:55 +0200 Nicolas Goaziou <mail@nicolasgoaziou.fr> wrote:
> The name of the phase looks like a copy-pasta typo. I overlooked it.
> I'll fix it in a subsequent commit.

Sorry about that! I overlooked it also.

I'll be more careful next time! Thanks for reviewing.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0f02f48c01..c41e7ce127 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -33477,6 +33477,41 @@  (define-public emacs-vundo
 the buffer you want to undo.  An undo tree buffer should pop up.")
     (license license:gpl3+)))
 
+(define-public emacs-org-cliplink
+  (let ((commit "13e0940b65d22bec34e2de4bc8cba1412a7abfbc")
+        (revision "0"))
+    (package
+      (name "emacs-org-cliplink")
+      (version (git-version "20201126" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/rexim/org-cliplink")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1avyiw8vlv4n1r7zqvc6wjlsz7jl2pqaprzpm782gzp0c999pssl"))))
+      (build-system emacs-build-system)
+      (arguments
+        (list
+         #:phases
+         #~(modify-phases %standard-phases
+             (add-after 'unpack 'patch-geiser-racket-binary
+               (lambda* (#:key inputs #:allow-other-keys)
+                 (substitute* "org-cliplink-transport.el"
+                   (("curl\")")
+                    (string-append (search-input-file inputs "bin/curl") "\")"))))))))
+      (inputs (list curl))
+      (home-page "https://github.com/rexim/org-cliplink/")
+      (synopsis "Insert org-mode links from the clipboard")
+      (description
+"@code{emacs-org-cliplink} provides a simple command that takes a URL
+from the clipboard and inserts an org-mode link with a title of a page
+found by the URL into the current buffer.")
+      (license license:expat))))
+
 (define-public emacs-project-x
   ;; There is no proper release.
   ;; The base version is extracted from the README.org.