diff mbox series

[bug#58615,2/2] gnu: Add python-watchpoints.

Message ID 20221018234250.17292-2-jgart@dismail.de
State New
Headers show
Series [bug#58615,1/2] gnu: Add python-objprint. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 18, 2022, 11:42 p.m. UTC
* gnu/packages/python-xyz.scm (python-watchpoints): New variable.
---
 gnu/packages/python-xyz.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5d1fa0c97f..9cf0946d66 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -31172,6 +31172,36 @@  (define-public python-objprint
 readable format.")
     (license license:asl2.0)))
 
+(define-public python-watchpoints
+  (package
+    (name "python-watchpoints")
+    (version "0.2.5")
+    ;; The tests are not included in the PyPI archive.
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/gaogaotiantian/watchpoints")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0d88vgjc99qp6wl3c3m3z2dyx46zb9vgfhwzwvbshay8g11fnfjp"))))
+    (build-system python-build-system)
+    (arguments
+      `(#:phases
+        (modify-phases %standard-phases
+          (replace 'check
+            (lambda* (#:key tests? inputs #:allow-other-keys)
+              (when tests?
+                (invoke "pytest" "-v")))))))
+    (native-inputs (list python-pytest python-pandas))
+    (propagated-inputs (list python-objprint))
+    (home-page "https://github.com/gaogaotiantian/watchpoints")
+    (synopsis "Monitor read and write on variables")
+    (description 
+"@code{python-watchpoints} monitors read and write on variables.")
+    (license license:asl2.0)))
+
 (define-public python-pymonad
   (package
     (name "python-pymonad")