diff mbox series

[bug#58610] gnu: rust-generic-array-0.14: Fix build.

Message ID 20221018145943.16919-1-mike@rohleder.de
State New
Headers show
Series [bug#58610] gnu: rust-generic-array-0.14: Fix build. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Oct. 18, 2022, 2:59 p.m. UTC
* gnu/packages/crates-io.scm (rust-generic-array-0.14)[arguments]: Add #:tests? #false.
---
 gnu/packages/crates-io.scm | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

Comments

Christopher Baines Oct. 21, 2022, 4:18 p.m. UTC | #1
Michael Rohleder <mike@rohleder.de> writes:

> * gnu/packages/crates-io.scm (rust-generic-array-0.14)[arguments]: Add #:tests? #false.
> ---
>  gnu/packages/crates-io.scm | 3 ++-
>  1 file changed, 2 insertions(+), 1 deletion(-)

This may fix the build, but instead we'd just be shipping software where
the test suite fails.

If we do want to go that way of disabling the test suite, I think it
would be good to make sure the issue is reported upstream, and link to
that bug report in the package definition, does that make sense?

Thanks,

Chris
Maxim Cournoyer Jan. 3, 2023, 10:02 p.m. UTC | #2
Hello Michael,

Christopher Baines <mail@cbaines.net> writes:

> Michael Rohleder <mike@rohleder.de> writes:
>
>> * gnu/packages/crates-io.scm (rust-generic-array-0.14)[arguments]: Add #:tests? #false.
>> ---
>>  gnu/packages/crates-io.scm | 3 ++-
>>  1 file changed, 2 insertions(+), 1 deletion(-)
>
> This may fix the build, but instead we'd just be shipping software where
> the test suite fails.
>
> If we do want to go that way of disabling the test suite, I think it
> would be good to make sure the issue is reported upstream, and link to
> that bug report in the package definition, does that make sense?

Friendly ping.
Michael Rohleder Jan. 6, 2023, 11:15 p.m. UTC | #3
Hello Christopher!

Thank you for reviewing and sorry for the delay!

Christopher Baines <mail@cbaines.net> writes:
> This may fix the build, but instead we'd just be shipping software where
> the test suite fails.
>
> If we do want to go that way of disabling the test suite, I think it
> would be good to make sure the issue is reported upstream, and link to
> that bug report in the package definition, does that make sense?

I guess this make a lot of sense, but I can't do this, because I don't
have any rust/cargo knowledge, no gh account etc.

This patch was just a quick hack to get synapse working.  I should have
thought about fixing it better than just disabling a test.

Sorry for the waste of time and the noise -> closing.
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 502972ffc5..afd1305018 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24886,7 +24886,8 @@  (define-public rust-generic-array-0.14
           "05qqwm9v5asbil9z28wjkmpfvs1c5c99n8n9gwxis3d3r3n6c52h"))))
     (build-system cargo-build-system)
     (arguments
-     `(#:cargo-inputs
+     `(#:tests? #false                  ;doc test fails
+       #:cargo-inputs
        (("rust-serde" ,rust-serde-1)
         ("rust-typenum" ,rust-typenum-1)
         ("rust-version-check" ,rust-version-check-0.9))