diff mbox series

[bug#58593] gnu: Add perl-regexp-grammars.

Message ID 20221017212601.14227-1-eu@euandre.org
State Accepted
Headers show
Series [bug#58593] gnu: Add perl-regexp-grammars. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

EuAndreh Oct. 17, 2022, 9:26 p.m. UTC
* gnu/packages/perl.scm (perl-regexp-grammars): New variable.
---

Formatted with './pre-inst-env guix style'.

 gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)

Comments

Christopher Baines Oct. 18, 2022, 10:23 a.m. UTC | #1
EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/perl.scm (perl-regexp-grammars): New variable.
> ---
>
> Formatted with './pre-inst-env guix style'.
>
>  gnu/packages/perl.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)

Thanks, pushed to master as 5595aa9a75f05440ae3c77b9bae282f89b7c47b8.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 022ca73429..e111fcd943 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -8843,6 +8843,30 @@  (define-public perl-regexp-common
     ;; Quad-licensed: Perl Artistic, Perl Artistic 2.0, X11, and BSD.
     (license (list (package-license perl) license:x11 license:bsd-3))))
 
+(define-public perl-regexp-grammars
+  (package
+    (name "perl-regexp-grammars")
+    (version "1.058")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/D/DC/DCONWAY/Regexp-Grammars-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "14hwskrmy6ma0k9nr1amrf7wpb1f6jsx7x29kgizlx0n4n7db27a"))))
+    (build-system perl-build-system)
+    (native-inputs (list perl-module-build perl-test-pod perl-moose))
+    (home-page "https://metacpan.org/release/Regexp-Grammars")
+    (synopsis "Complete recursive descent parser on Perl's regex engine")
+    (description
+     "The @code{Regexp::Grammars} module adds a small number of new
+regex constructs that can be used within Perl 5.10 patterns to implement
+complete recursive-descent parsing.  It allows you to go beyond matching
+complex, nested and recursive structures, and allows you to parse and extract
+hierarchical data from it.")
+    (license license:perl-license)))
+
 (define-public perl-regexp-util
   (package
     (name "perl-regexp-util")