diff mbox series

[bug#58588] gnu: Add perl-commonmark.

Message ID 20221017203843.7160-1-eu@euandre.org
State Accepted
Headers show
Series [bug#58588] gnu: Add perl-commonmark. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

EuAndreh Oct. 17, 2022, 8:38 p.m. UTC
* gnu/packages/markup.scm (perl-commonmark): New variable.
---

Formatted with './pre-inst-env guix style'.

 gnu/packages/markup.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

Comments

Christopher Baines Oct. 18, 2022, 10:22 a.m. UTC | #1
EuAndreh via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/markup.scm (perl-commonmark): New variable.
> ---
>
> Formatted with './pre-inst-env guix style'.
>
>  gnu/packages/markup.scm | 28 ++++++++++++++++++++++++++++
>  1 file changed, 28 insertions(+)

Thanks, pushed to master as 6d32d835aa40f655a42422765348cae9ba8eb334.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/markup.scm b/gnu/packages/markup.scm
index 791035deb3..35dd6d257b 100644
--- a/gnu/packages/markup.scm
+++ b/gnu/packages/markup.scm
@@ -46,6 +46,7 @@  (define-module (gnu packages markup)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages libffi)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages perl-check)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-xyz)
@@ -360,6 +361,33 @@  (define-public cmark
     ;; licensed. See 'COPYING' in the source distribution for more information.
     (license (list license:bsd-2 license:expat license:cc-by-sa4.0))))
 
+(define-public perl-commonmark
+  (package
+    (name "perl-commonmark")
+    (version "0.290000")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "mirror://cpan/authors/id/N/NW/NWELLNHOF/CommonMark-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "1pgaqa4f00i9r5z7l9xiya0q51ysq0nhpvgr0f3rza3cxz1v80d5"))))
+    (build-system perl-build-system)
+    (arguments
+     `(#:make-maker-flags
+       ;; MakeMaker ignores LIBRARY_PATH.
+       (list (format #f "LIBS=-L~a/lib -lcmark"
+                     (assoc-ref %build-inputs "cmark")))))
+    (inputs (list cmark perl-test-leaktrace perl-devel-checklib
+                  perl-module-build))
+    (home-page "https://metacpan.org/release/CommonMark")
+    (synopsis "Interface to the CommonMark C library")
+    (description
+     "This module is an XS wrapper around the official
+CommonMark C library libcmark.  It closely follows the original API.")
+    (license license:perl-license)))
+
 (define-public cmark-gfm
   (package
     (inherit cmark)