diff mbox series

[bug#58587,14/14] gnu: python-pygmsh: Use pyproject-build-system.

Message ID 20221017201201.4808-14-marius@gnu.org
State New
Headers show
Series Introducing pyproject-build-system. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Marius Bakke Oct. 17, 2022, 8:12 p.m. UTC
* gnu/packages/simulation.scm (python-pygmsh)[build-system]: Switch to
PYPROJECT-BUILD-SYSTEM.
[arguments]: Remove redundant phases.
[native-inputs]: Remove PYTHON-PYPA-BUILD.
---
 gnu/packages/simulation.scm | 20 ++++----------------
 1 file changed, 4 insertions(+), 16 deletions(-)

Comments

Maxim Cournoyer Oct. 27, 2022, 2:26 p.m. UTC | #1
Hi,

Marius Bakke <marius@gnu.org> writes:

> * gnu/packages/simulation.scm (python-pygmsh)[build-system]: Switch to
> PYPROJECT-BUILD-SYSTEM.
> [arguments]: Remove redundant phases.
> [native-inputs]: Remove PYTHON-PYPA-BUILD.

LGTM, as well as all the previous patches switching to
pyproject-build-system.

Well done! :-)
diff mbox series

Patch

diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 39b5620822..57a7882765 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -57,6 +57,7 @@  (define-module (gnu packages simulation)
   #:use-module (guix svn-download)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system pyproject)
   #:use-module (guix build-system python)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
@@ -828,7 +829,7 @@  (define-public python-pygmsh
        (sha256
         (base32
          "11flp2c4ynk1fhanf4mqyzrpd0gjbnv6afrwwc7xi3mb6ms69lr0"))))
-    (build-system python-build-system)
+    (build-system pyproject-build-system)
     (arguments
      (list
       #:phases
@@ -838,21 +839,8 @@  (define-public python-pygmsh
               ;; Due to lack of metadata, the gmsh Python package is not
               ;; detected although importable.
               (substitute* "pyproject.toml"
-                (("\"gmsh\",") ""))))
-          ;; XXX: PEP 517 manual build copied from python-isort.
-          (replace 'build
-            (lambda _
-              (invoke "python" "-m" "build" "--wheel" "--no-isolation" ".")))
-          (replace 'check
-            (lambda* (#:key tests? #:allow-other-keys)
-              (when tests?
-                (invoke "pytest" "-v" "tests"))))
-          (replace 'install
-            (lambda _
-              (let ((whl (car (find-files "dist" "\\.whl$"))))
-                (invoke "pip" "--no-cache-dir" "--no-input"
-                        "install" "--no-deps" "--prefix" #$output whl)))))))
-    (native-inputs (list python-pypa-build python-flit-core python-pytest))
+                (("\"gmsh\",") "")))))))
+    (native-inputs (list python-flit-core python-pytest))
     (propagated-inputs (list gmsh python-meshio python-numpy))
     (home-page "https://github.com/nschloe/pygmsh")
     (synopsis "Python frontend for Gmsh")