diff mbox series

[bug#58585,1/2] gnu: mako: Patch makoctl to refer directly to binaries.

Message ID 20221017164703.14949-1-paren@disroot.org
State New
Headers show
Series gnu: home: Add home-mako-service-type. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Oct. 17, 2022, 4:47 p.m. UTC
* gnu/packages/wm.scm (mako)[arguments]<#:phases>{'patch-makoctl}:
  New phase.
[inputs]: Add jq.
---
 gnu/packages/wm.scm | 36 ++++++++++++++++++++++++++----------
 1 file changed, 26 insertions(+), 10 deletions(-)

Comments

Andrew Tropin Nov. 10, 2022, 12:59 p.m. UTC | #1
On 2022-10-17 17:47, guix-patches@gnu.org wrote:

> * gnu/packages/wm.scm (mako)[arguments]<#:phases>{'patch-makoctl}:
>   New phase.
> [inputs]: Add jq.
> ---
>  gnu/packages/wm.scm | 36 ++++++++++++++++++++++++++----------
>  1 file changed, 26 insertions(+), 10 deletions(-)
>
> diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
> index af406ed2ed..d96846a21c 100644
> --- a/gnu/packages/wm.scm
> +++ b/gnu/packages/wm.scm
> @@ -58,6 +58,7 @@
>  ;;; Copyright © 2022 Elais Player <elais@fastmail.com>
>  ;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
>  ;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
> +;;; Copyright © 2022 ( <paren@disroot.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -1807,17 +1808,32 @@ (define-public mako
>    (package
>      (name "mako")
>      (version "1.7.1")
> -    (source
> -     (origin
> -       (method git-fetch)
> -       (uri (git-reference
> -             (url "https://github.com/emersion/mako")
> -             (commit (string-append "v" version))))
> -       (file-name (git-file-name name version))
> -       (sha256
> -        (base32 "0vpar1a7zafkd2plmyaackgba6fyg35s9zzyxmj8j7v2q5zxirgz"))))
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/emersion/mako")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +                "0vpar1a7zafkd2plmyaackgba6fyg35s9zzyxmj8j7v2q5zxirgz"))))
>      (build-system meson-build-system)
> -    (inputs (list basu cairo gdk-pixbuf pango wayland))
> +    (arguments
> +     (list #:phases
> +           #~(modify-phases %standard-phases
> +               (add-after 'unpack 'patch-makoctl
> +                 (lambda* (#:key inputs #:allow-other-keys)
> +                   (substitute* "makoctl"
> +                     (("^BUSCTL=.*$")
> +                      (string-append
> +                       "BUSCTL="
> +                       (search-input-file inputs "bin/basuctl")
> +                       "\n"))
> +                     (("jq ")
> +                      (string-append
> +                       (search-input-file inputs "bin/jq")
> +                       " "))))))))
> +    (inputs (list basu cairo gdk-pixbuf jq pango wayland))
>      (native-inputs (list pkg-config scdoc wayland-protocols))
>      (home-page "https://wayland.emersion.fr/mako")
>      (synopsis "Lightweight Wayland notification daemon")

Applied this patch and pushed, thank you.
diff mbox series

Patch

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index af406ed2ed..d96846a21c 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2022 Elais Player <elais@fastmail.com>
 ;;; Copyright © 2022 Trevor Richards <trev@trevdev.ca>
 ;;; Copyright © 2022 Fredrik Salomonsson <plattfot@posteo.net>
+;;; Copyright © 2022 ( <paren@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1807,17 +1808,32 @@  (define-public mako
   (package
     (name "mako")
     (version "1.7.1")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             (url "https://github.com/emersion/mako")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0vpar1a7zafkd2plmyaackgba6fyg35s9zzyxmj8j7v2q5zxirgz"))))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/emersion/mako")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "0vpar1a7zafkd2plmyaackgba6fyg35s9zzyxmj8j7v2q5zxirgz"))))
     (build-system meson-build-system)
-    (inputs (list basu cairo gdk-pixbuf pango wayland))
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'patch-makoctl
+                 (lambda* (#:key inputs #:allow-other-keys)
+                   (substitute* "makoctl"
+                     (("^BUSCTL=.*$")
+                      (string-append
+                       "BUSCTL="
+                       (search-input-file inputs "bin/basuctl")
+                       "\n"))
+                     (("jq ")
+                      (string-append
+                       (search-input-file inputs "bin/jq")
+                       " "))))))))
+    (inputs (list basu cairo gdk-pixbuf jq pango wayland))
     (native-inputs (list pkg-config scdoc wayland-protocols))
     (home-page "https://wayland.emersion.fr/mako")
     (synopsis "Lightweight Wayland notification daemon")