diff mbox series

[bug#58566,core-updates] gnu: mesa: Update to 22.2.1.

Message ID 20221016165127.23333-1-kaelyn.alexi@protonmail.com
State New
Headers show
Series [bug#58566,core-updates] gnu: mesa: Update to 22.2.1. | expand

Checks

Context Check Description
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

Kaelyn Takata Oct. 16, 2022, 4:51 p.m. UTC
* gnu/packages/gl.scm (mesa): Update to 22.1.7.
[phases]: Add phase to insert the full store path to the vulkan layer
shared libraries into the layer manifests so the vulkan loader can find
the layer shared libraries.
---
 gnu/packages/gl.scm | 27 ++++++++++++++++++++++++---
 1 file changed, 24 insertions(+), 3 deletions(-)

--
2.37.3

Comments

Kaelyn Takata Nov. 21, 2022, 7:16 p.m. UTC | #1
I've just created https://issues.guix.gnu.org/59453 with the patch to mesa on core-updates to fix the library paths in the Vulkan layer manifests. I split the change out from my previous mesa update patch (https://issues.guix.gnu.org/58566) as mesa on core-updates has since been updated to version 22.2.4.
diff mbox series

Patch

diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 7810d1d8ae..895c9c1b54 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -267,7 +267,7 @@  (define libva-without-mesa
 (define-public mesa
   (package
     (name "mesa")
-    (version "22.1.7")
+    (version "22.2.1")
     (source
      (origin
        (method url-fetch)
@@ -279,7 +279,7 @@  (define-public mesa
                                  version "/mesa-" version ".tar.xz")))
        (sha256
         (base32
-         "12ax6lmshc8aqzw5ca7ab7f7z64n9nyzci4r1s6y1l0iryr8x0ys"))))
+         "0g5ij57ljh3l04qf7qpildl45g5g7s8ycngc19z5xx1k1anbwy80"))))
     (build-system meson-build-system)
     (propagated-inputs
      ;; The following are in the Requires.private field of gl.pc.
@@ -488,7 +488,28 @@  (define-public mesa
                                                        file)
                                               (symlink reference file)))
                                         others))))
-                         (delete-duplicates inodes))))))))
+                         (delete-duplicates inodes)))))
+         (add-after 'install 'set-layer-path-in-manifests
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (implicit-path (string-append
+                                    out
+                                    "/share/vulkan/implicit_layer.d/"))
+                    (explicit-path (string-append
+                                    out
+                                    "/share/vulkan/explicit_layer.d/"))
+                    (fix-layer-path
+                     (lambda (layer-name)
+                       (let* ((explicit (string-append explicit-path layer-name ".json"))
+                              (implicit (string-append implicit-path layer-name ".json"))
+                              (manifest (if (file-exists? explicit)
+                                            explicit
+                                            implicit)))
+                         (substitute* manifest
+                           (((string-append "\"lib" layer-name ".so\""))
+                             (string-append "\"" out "/lib/lib" layer-name ".so\"")))))))
+               (for-each fix-layer-path '("VkLayer_MESA_device_select"
+                                          "VkLayer_MESA_overlay"))))))))
     (home-page "https://mesa3d.org/")
     (synopsis "OpenGL and Vulkan implementations")
     (description "Mesa is a free implementation of the OpenGL and Vulkan