diff mbox series

[bug#46946,1/2] gnu: Add python-bioframe.

Message ID 20221014225218.13626-1-madalinionel.patrascu@mdc-berlin.de
State New
Headers show
Series [bug#46946,1/2] gnu: Add python-bioframe. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Mădălin Ionel Patrașcu Oct. 14, 2022, 10:52 p.m. UTC
X-Debbugs-Cc: rekado@elephly.net

* gnu/packages/bioinformatics.scm (python-bioframe): New variable.
---
 gnu/packages/bioinformatics.scm | 46 +++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)


base-commit: 10d429f2fce321d8285684503094694ec3979865
diff mbox series

Patch

diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f2de09aa32..1478ba0c46 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -946,6 +946,52 @@  (define (cythonized? c/c++-file)
     ;; licensed lgpl2.1+
     (license (list license:expat license:lgpl2.1+))))
 
+(define-public python-bioframe
+  (package
+    (name "python-bioframe")
+    (version "0.3.3")
+    (source
+      (origin
+        (method git-fetch)
+        ;; pypi version does not contain tests and requirements.txt
+        (uri (git-reference
+               (url "https://github.com/open2c/bioframe")
+               (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "14lvb18d4npapyi6j2zqh9q94l658dzmka5riiizw1h0zb0kp9xb"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda* (#:key tests? #:allow-other-keys)
+             (setenv "MPLCONFIGDIR" "/tmp")
+             (when tests?
+               (invoke "pytest" "-v")))))))
+    (native-inputs
+      (list python-biopython
+            python-pysam
+            python-pytest
+            python-wheel))
+    (propagated-inputs
+      (list python-matplotlib
+            python-numpy
+            python-pandas
+            python-requests))
+    (home-page "https://github.com/open2c/bioframe")
+    (synopsis "Pandas utilities for tab-delimited and other genomic files")
+    (description
+     "This package is a library to enable flexible and scalable operations on
+genomic interval dataframes in @code{python}.  @code{python-bioframe} enables
+access to a rich set of dataframe operations.  Working in @code{python} enables
+rapid visualization (e.g. @code{matplotlib}, @code{seaborn}) and iteration of
+genomic analyses.  The philosophy underlying @code{python-bioframe} is to enable
+flexible operations.  Instead of creating a function for every possible use-case,
+we encourage users to compose functions to achieve their goals.")
+    (license license:expat)))
+
 (define-public python-biom-format
   (package
     (name "python-biom-format")