diff mbox series

[bug#58514] gnu: Add s3cmd.

Message ID 20221014133701.4764-1-kraai@ftbfs.org
State Accepted
Headers show
Series [bug#58514] gnu: Add s3cmd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Matthew James Kraai Oct. 14, 2022, 1:37 p.m. UTC
* gnu/packages/python-xyz.scm (python-s3cmd): New variable.
---
 gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

Comments

Christopher Baines Oct. 16, 2022, 6:34 p.m. UTC | #1
Matthew James Kraai <kraai@ftbfs.org> writes:

> * gnu/packages/python-xyz.scm (python-s3cmd): New variable.
> ---
>  gnu/packages/python-xyz.scm | 28 +++++++++++++++++++++++++++-
>  1 file changed, 27 insertions(+), 1 deletion(-)

Thanks Matthew, I've gone ahead and pushed this to master as
cf19228932eff2ede5f39f4fdc759374e3b89991.

I made a few tweaks, all around packaging this more as a tool than a
Python library. I made the inputs plain inputs rather than propagated
inputs, since that'll interfere less with users profiles, and I also
just named the package s3cmd, since the python bit is not particularly
relevant.

Thanks again,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7c647bd42f..3c5b247df8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -75,7 +75,7 @@ 
 ;;; Copyright © 2020 Josh Marshall <joshua.r.marshall.1991@gmail.com>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
 ;;; Copyright © 2020 Alex ter Weele <alex.ter.weele@gmail.com>
-;;; Copyright © 2020 Matthew James Kraai <kraai@ftbfs.org>
+;;; Copyright © 2020, 2022 Matthew James Kraai <kraai@ftbfs.org>
 ;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
 ;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
 ;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
@@ -16189,6 +16189,32 @@  (define-public python-magic
 the same purpose: to provide Python bindings for libmagic.")
     (license license:expat)))
 
+(define-public python-s3cmd
+  (package
+    (name "python-s3cmd")
+    (version "2.3.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/s3tools/s3cmd")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0rdgwwmmp8mdxc84bxq6k9a7v7z2qgc3df47djzs2b84gw81dglx"))))
+    (build-system python-build-system)
+    (propagated-inputs
+     (list python-dateutil python-magic))
+    (home-page "https://s3tools.org/s3cmd")
+    (synopsis "Command line tool for S3-compatible storage services")
+    (description
+     "S3cmd is a command line tool for uploading, retrieving and managing data
+in storage services that are compatible with the Amazon Simple Storage
+Service (S3) protocol, including S3 itself.  It supports rsync-like backup,
+GnuPG encryption, and more.  It also supports management of Amazon's
+CloudFront content delivery network.")
+    (license license:gpl2+)))
+
 (define-public python-pkgconfig
   (package
     (name "python-pkgconfig")