diff mbox series

[bug#58488] gnu: gnome: Include aarch64 in librsvg-for-system.

Message ID 20221013102048.22966-1-mail@cbaines.net
State New
Headers show
Series [bug#58488] gnu: gnome: Include aarch64 in librsvg-for-system. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Christopher Baines Oct. 13, 2022, 10:20 a.m. UTC
Since the staging merge, librsvg has been buildable for aarch64.

* gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
---
 gnu/packages/gnome.scm | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Oct. 23, 2022, 1:10 p.m. UTC | #1
Hi Chris,

Christopher Baines <mail@cbaines.net> skribis:

> Since the staging merge, librsvg has been buildable for aarch64.
>
> * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.

[...]

> +  ;; on x86_64 and aarch64 so far, use the ancient C version on other
> +  ;; platforms (FIXME).
> +  (if (or (string-prefix? "x86_64-" system)
> +          (string-prefix? "aarch64-" system))
>        librsvg
>        librsvg-2.40))

Looks like a reasonable workaround to me.  Go for it!

Thanks,
Ludo’.
Ludovic Courtès Nov. 3, 2022, 3:32 p.m. UTC | #2
Christopher Baines <mail@cbaines.net> skribis:

> Since the staging merge, librsvg has been buildable for aarch64.
>
> * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
> ---
>  gnu/packages/gnome.scm | 6 ++++--
>  1 file changed, 4 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 09a991b14c..ff9d95c244 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -3753,8 +3753,10 @@ (define* (librsvg-for-system #:optional
>                               (system (or (%current-target-system)
>                                           (%current-system))))
>    ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
> -  ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
> -  (if (string-prefix? "x86_64-" system)
> +  ;; on x86_64 and aarch64 so far, use the ancient C version on other
> +  ;; platforms (FIXME).
> +  (if (or (string-prefix? "x86_64-" system)
> +          (string-prefix? "aarch64-" system))

With <https://issues.guix.gnu.org/58661> now fixed, I think you can go
ahead and push this one, no?

Ludo’.
Christopher Baines Nov. 3, 2022, 4:46 p.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> writes:

> Christopher Baines <mail@cbaines.net> skribis:
>
>> Since the staging merge, librsvg has been buildable for aarch64.
>>
>> * gnu/packages/gnome.scm (librsvg-for-system): Use librsvg for aarch64.
>> ---
>>  gnu/packages/gnome.scm | 6 ++++--
>>  1 file changed, 4 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
>> index 09a991b14c..ff9d95c244 100644
>> --- a/gnu/packages/gnome.scm
>> +++ b/gnu/packages/gnome.scm
>> @@ -3753,8 +3753,10 @@ (define* (librsvg-for-system #:optional
>>                               (system (or (%current-target-system)
>>                                           (%current-system))))
>>    ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
>> -  ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
>> -  (if (string-prefix? "x86_64-" system)
>> +  ;; on x86_64 and aarch64 so far, use the ancient C version on other
>> +  ;; platforms (FIXME).
>> +  (if (or (string-prefix? "x86_64-" system)
>> +          (string-prefix? "aarch64-" system))
>
> With <https://issues.guix.gnu.org/58661> now fixed, I think you can go
> ahead and push this one, no?

Indeed, thanks for the reminder, I've pushed to master as
754f260753fb6ebe28325616bc08336a184e4621.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 09a991b14c..ff9d95c244 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3753,8 +3753,10 @@  (define* (librsvg-for-system #:optional
                              (system (or (%current-target-system)
                                          (%current-system))))
   ;; Since librsvg 2.50 depends on Rust, and Rust is only correctly supported
-  ;; on x86_64 so far, use the ancient C version on other platforms (FIXME).
-  (if (string-prefix? "x86_64-" system)
+  ;; on x86_64 and aarch64 so far, use the ancient C version on other
+  ;; platforms (FIXME).
+  (if (or (string-prefix? "x86_64-" system)
+          (string-prefix? "aarch64-" system))
       librsvg
       librsvg-2.40))