diff mbox series

[bug#58465] gnu: Add guile-dns.

Message ID 20221012094801.32218-1-arunisaac@systemreboot.net
State Accepted
Headers show
Series [bug#58465] gnu: Add guile-dns. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Arun Isaac Oct. 12, 2022, 9:48 a.m. UTC
* gnu/packages/guile-xyz.scm (guile-dns): New variable.
---
 gnu/packages/guile-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

Comments

Christopher Baines Oct. 13, 2022, 10:05 a.m. UTC | #1
Arun Isaac <arunisaac@systemreboot.net> writes:

> * gnu/packages/guile-xyz.scm (guile-dns): New variable.
> ---
>  gnu/packages/guile-xyz.scm | 36 ++++++++++++++++++++++++++++++++++++
>  1 file changed, 36 insertions(+)

This looks to fail to build on i686-linux:

  https://qa.guix.gnu.org/issue/58465

Given this is a new package, ideally we'd either fix that, or change the
supported systems to match what builds.

Thanks,

Chris
Arun Isaac Oct. 14, 2022, 8:40 p.m. UTC | #2
Hi Chris,

> This looks to fail to build on i686-linux:
>
>   https://qa.guix.gnu.org/issue/58465

Good catch, and love the new QA system! :-)

> Given this is a new package, ideally we'd either fix that, or change the
> supported systems to match what builds.

Disabling the coverage report fixes this. Is that a satisfactory
solution? A patch follows.

Thanks,
Arun
Christopher Baines Oct. 15, 2022, 8:30 p.m. UTC | #3
Arun Isaac <arunisaac@systemreboot.net> writes:

>> This looks to fail to build on i686-linux:
>>
>>   https://qa.guix.gnu.org/issue/58465
>
> Good catch, and love the new QA system! :-)
>
>> Given this is a new package, ideally we'd either fix that, or change the
>> supported systems to match what builds.
>
> Disabling the coverage report fixes this. Is that a satisfactory
> solution? A patch follows.

Yeah, that sounds fine to me, please go ahead and push :)
Arun Isaac Oct. 16, 2022, 8:37 a.m. UTC | #4
Pushed, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 379d9aa264..b7909e8f8d 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4426,6 +4426,42 @@  (define-public guile-avahi
       (home-page "https://www.nongnu.org/guile-avahi/")
       (license license:lgpl3+))))
 
+(define-public guile-dns
+  (package
+    (name "guile-dns")
+    (version "0.1")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.lysator.liu.se/hugo/guile-dns")
+                    (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "18skivracv6jh1zab9dknkcpbizc416n0pb2mcwb20dpzc2md9yf"))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:make-flags #~(list (string-append "PREFIX=" #$output))
+           #:phases
+           #~(modify-phases %standard-phases
+               (add-after 'unpack 'prefer-curdir
+                 (lambda _
+                   ;; CURDIR is a standard GNU Make variable. Prefer it to
+                   ;; PWD. PWD is set by the shell and is absent in the build
+                   ;; process.
+                   (substitute* "Makefile"
+                     (("PWD") "CURDIR"))))
+               (delete 'configure))))
+    (inputs
+     (list guile-3.0))
+    (native-inputs
+     (list texinfo))
+    (home-page "https://git.lysator.liu.se/hugo/guile-dns")
+    (synopsis "Guile DNS library")
+    (description "@code{guile-dns} is a DNS library written in pure Guile
+Scheme.")
+    (license license:gpl3+)))
+
 (define-public guile-jwt
   (package
     (name "guile-jwt")