diff mbox series

[bug#58461] gnu: emacs-eval-in-repl-erlang: Fix unbound variable.

Message ID 20221012022043.yclajntlesut5i42@peregrine
State Accepted
Headers show
Series [bug#58461] gnu: emacs-eval-in-repl-erlang: Fix unbound variable. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Brian Kubisiak Oct. 12, 2022, 2:20 a.m. UTC
Commit 0b120ad5f88d32e0c716b1442fe1ea3c562b5586 introduced a circular
dependency where (gnu packages erlang) would transitively load (gnu
packages emacs-xyz) before the emacs-erlang package was defined. This
would result in "error: emacs-erlang: unbound variable" in the
definition of emacs-eval-in-repl-erlang when trying to use (gnu
packages erlang) from the repl.

This commit fixes the unbound variable by adding a delay to the inputs
in make-emacs-eval-in-repl.

* gnu/packages/emacs-xyz.scm (emacs-eval-in-repl-erlang): Add delay.
---
 gnu/packages/emacs-xyz.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comments

Liliana Marie Prikler Oct. 14, 2022, 9:52 p.m. UTC | #1
Am Dienstag, dem 11.10.2022 um 19:20 -0700 schrieb Brian Kubisiak:
> Commit 0b120ad5f88d32e0c716b1442fe1ea3c562b5586 introduced a circular
> dependency where (gnu packages erlang) would transitively load (gnu
> packages emacs-xyz) before the emacs-erlang package was defined. This
> would result in "error: emacs-erlang: unbound variable" in the
> definition of emacs-eval-in-repl-erlang when trying to use (gnu
> packages erlang) from the repl.
> 
> This commit fixes the unbound variable by adding a delay to the
> inputs in make-emacs-eval-in-repl.
Pushed with a slightly shorter commit message.

Cheers
Christopher Baines Oct. 16, 2022, 5:12 p.m. UTC | #2
Marking as done as the patch has been pushed to master.
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2ac29e8225..1b0f07731d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27911,7 +27911,7 @@  (define-public emacs-eval-in-repl-elm
   (make-emacs-eval-in-repl "elm" #:inputs (list emacs-elm-mode)))
 
 (define-public emacs-eval-in-repl-erlang
-  (make-emacs-eval-in-repl "erlang" #:inputs (list emacs-erlang)))
+  (make-emacs-eval-in-repl "erlang" #:inputs (delay (list emacs-erlang))))
 
 (define-public emacs-eval-in-repl-geiser
   (make-emacs-eval-in-repl "geiser" #:language "Scheme"