diff mbox series

[bug#58460] gnu: Add erlang-yamerl.

Message ID 20221012010722.11525-1-jgart@dismail.de
State New
Headers show
Series [bug#58460] gnu: Add erlang-yamerl. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 12, 2022, 1:07 a.m. UTC
* gnu/packages/erlang.scm (erlang-yamerl): New variable.
---
 gnu/packages/erlang.scm | 20 ++++++++++++++++++++
 1 file changed, 20 insertions(+)

Comments

Christopher Baines Dec. 12, 2022, 10:53 p.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/erlang.scm (erlang-yamerl): New variable.
> ---
>  gnu/packages/erlang.scm | 20 ++++++++++++++++++++
>  1 file changed, 20 insertions(+)

I've now tweaked the description and pushed this to master as
1d160f41f5e973ea2bbbf8bc80d216b5d9b0974c.

Thanks,

Chris
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 0e9d79f2ee..973d668553 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -281,6 +281,26 @@  (define-public erlang-cf
 printing extending the io:format syntax to add colours.")
     (license license:expat)))
 
+(define-public erlang-yamerl
+  (package
+    (name "erlang-yamerl")
+    (version "0.10.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             ;; There are no tests included on Hex.
+             (url "https://github.com/yakaz/yamerl")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0if8abgmispcfk7zhd0a5dndzwzbsmqrbyrm5shk375r2dbbwak6"))))
+    (build-system rebar-build-system)
+    (synopsis "YAML and JSON parser in pure Erlang")
+    (description "YAML and JSON parser in pure Erlang.")
+    (home-page "https://hexdocs.pm/yamerl/")
+    (license license:bsd-2)))
+
 (define-public erlang-covertool
   (package
     (name "erlang-covertool")