diff mbox series

[bug#58458] gnu: Add erlang-jsx.

Message ID 20221011221921.25399-1-jgart@dismail.de
State New
Headers show
Series [bug#58458] gnu: Add erlang-jsx. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

jgart Oct. 11, 2022, 10:19 p.m. UTC
* gnu/packages/erlang.scm (erlang-jsx): New variable.
---
 gnu/packages/erlang.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)

Comments

Christopher Baines Dec. 12, 2022, 10:52 p.m. UTC | #1
jgart via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/erlang.scm (erlang-jsx): New variable.
> ---
>  gnu/packages/erlang.scm | 18 ++++++++++++++++++
>  1 file changed, 18 insertions(+)

Thanks, I fixed the indentation for the description line and I changed
the home-page URL to one that works, and pushed this to master as
e4fd04fb92e2da769ca521eba877bbcd936f290e.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index ede46f3a1c..0e9d79f2ee 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -7,6 +7,7 @@ 
 ;;; Copyright © 2020-2022 Hartmut Goebel <h.goebel@crazy-compilers.com>
 ;;; Copyright © 2021 Oskar Köök <oskar@maatriks.ee>
 ;;; Copyright © 2021 Cees de Groot <cg@evrl.com>
+;;; Copyright © 2022 jgart <jgart@dismail.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -499,6 +500,23 @@  (define-public erlang-proper
 testing of stateful systems.")
     (license license:gpl3+)))
 
+(define-public erlang-jsx
+  (package
+    (name "erlang-jsx")
+    (version "3.1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (hexpm-uri "jsx" version))
+              (sha256
+               (base32
+                "1wr7jkxm6nlgvd52xhniav64xr9rml2ngb35rwjwqlqvq7ywhp0c"))))
+    (build-system rebar-build-system)
+    (synopsis "Streaming, evented JSON parsing toolkit")
+    (description 
+"An Erlang application for consuming, producing and manipulating json.")
+    (home-page "https://hexdocs.pm/jsx/")
+    (license license:expat)))
+
 (define-public erlang-providers
   (package
     (name "erlang-providers")