diff mbox series

[bug#58432] gnu: Add hiredis

Message ID 20221011130834.1592-1-thomas@thomaslabs.org
State Accepted
Headers show
Series [bug#58432] gnu: Add hiredis | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola Oct. 11, 2022, 1:08 p.m. UTC
* gnu/packages/databases.scm (hiredis): New variable.
---
 gnu/packages/databases.scm | 28 +++++++++++++++++++++++++++-
 1 file changed, 27 insertions(+), 1 deletion(-)

--
2.37.3

Comments

\( Oct. 11, 2022, 1:34 p.m. UTC | #1
LGTM :)

    -- (
Christopher Baines Oct. 13, 2022, 10:10 a.m. UTC | #2
Thomas Albers via Guix-patches via <guix-patches@gnu.org> writes:

> * gnu/packages/databases.scm (hiredis): New variable.
> ---
>  gnu/packages/databases.scm | 28 +++++++++++++++++++++++++++-
>  1 file changed, 27 insertions(+), 1 deletion(-)

Thanks both, I've pushed this to master as
cc58a0c62739d93c1d22a9930f11abdb0bd7ac04.

Chris
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cf07832df7..8523c084e4 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2494,6 +2495,31 @@  (define-public redis
     (home-page "https://redis.io/")
     (license license:bsd-3)))

+(define-public hiredis
+  (package
+    (name "hiredis")
+    (version "1.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/redis/hiredis")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     ;; needed for testing
+     (list redis))
+    (synopsis "Minimalistic C client library for the Redis database")
+    (description "This package provides a library for sending commands and
+receiving replies to and from a Redis server.  It comes with a synchronous
+API, asynchronous API and reply parsing API.  Only the binary-safe Redis
+protocol is supported.")
+    (home-page "https://github.com/redis/hiredis")
+    (license license:bsd-3)))
+
 (define-public ruby-redis
   (package
     (name "ruby-redis")