diff mbox series

[bug#58436] gnu: Add hunspell-dict-hu.

Message ID 20221011120218.22347-1-attila@lendvai.name
State Accepted
Headers show
Series [bug#58436] gnu: Add hunspell-dict-hu. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Attila Lendvai Oct. 11, 2022, 12:02 p.m. UTC
---

builds it from source.

testing method: after including this in the profile, LibreOffice Writer started to underline typos in hungarian paragraphs.

 gnu/packages/libreoffice.scm | 50 ++++++++++++++++++++++++++++++++++++
 1 file changed, 50 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 46eba12431..1991be9193 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -46,6 +46,7 @@  (define-module (gnu packages libreoffice)
   #:use-module (gnu packages aspell)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
+  #:use-module (gnu packages bash)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
@@ -60,6 +61,7 @@  (define-module (gnu packages libreoffice)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages game-development)
+  #:use-module (gnu packages gawk)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -73,6 +75,7 @@  (define-module (gnu packages libreoffice)
   #:use-module (gnu packages java)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages logging)
+  #:use-module (gnu packages m4)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages nss)
   #:use-module (gnu packages openldap)
@@ -83,6 +86,7 @@  (define-module (gnu packages libreoffice)
   #:use-module (gnu packages python)
   #:use-module (gnu packages rdf)
   #:use-module (gnu packages scanner)
+  #:use-module (gnu packages textutils)
   #:use-module (gnu packages tls)
   #:use-module (gnu packages version-control)
   #:use-module (gnu packages xml)
@@ -996,6 +1000,52 @@  (define-public hyphen
     (license
      (list license:mpl1.1 license:mpl2.0 license:gpl2+ license:lgpl2.1+))))
 
+(define-public hunspell-dict-hu
+  (let ((revision "2")
+        (major+minor "1.7"))
+    (package
+      (name "hunspell-dict-hu")
+      (version (string-append major+minor "-" revision))
+      (source
+       (origin
+         (method url-fetch)
+         (uri (string-append "mirror://sourceforge/magyarispell/Magyar Ispell/"
+                             major+minor
+                             "/magyarispell-" version ".tar.gz"))
+         (sha256
+          (base32 "0r22rvqrp5bzgr9sqyap82kibi5z9n6xy5b06si28idqijw7c772"))))
+      (build-system gnu-build-system)
+      (arguments
+       (list
+        #:make-flags
+        #~(list
+           "myspell"
+           "--jobs=1" ; the Makefile is not ready for parallelism
+           (string-append "SH="  (search-input-file %build-inputs "/bin/bash"))
+           (string-append "AWK=" (search-input-file %build-inputs "/bin/awk")))
+        #:phases
+        #~(modify-phases %standard-phases
+            (replace 'configure
+              (lambda* (#:key outputs #:allow-other-keys)
+                (substitute* "config"
+                  (("/usr/bin/awk")
+                   (search-input-file %build-inputs "/bin/awk")))))
+            (replace 'install           ;no install target
+              (lambda* (#:key outputs #:allow-other-keys)
+                (let* ((out (assoc-ref outputs "out"))
+                       (share (string-append out "/share/hunspell/")))
+                  (install-file "hu_HU.aff" share)
+                  (install-file "hu_HU.dic" share)
+                  #t))))
+          #:tests? #f))                  ; no tests
+      (native-inputs
+       (list bash-minimal gawk hunspell m4 recode))
+      (synopsis "Hunspell dictionary for Hungarian (hu_HU)")
+      (description "This package provides a dictionary for the Hunspell
+spell-checking library.")
+      (home-page "http://magyarispell.sourceforge.net/")
+      (license (list license:gpl2 license:gpl3)))))
+
 (define-public mythes
   (package
     (name "mythes")