diff mbox series

[bug#58432] gnu: Add hiredis

Message ID 20221011091949.9962-1-thomas@thomaslabs.org
State Accepted
Headers show
Series [bug#58432] gnu: Add hiredis | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Thomas Albers Raviola Oct. 11, 2022, 9:19 a.m. UTC
* gnu/packages/databases.scm (hiredis): New variable.
---
 gnu/packages/databases.scm | 26 +++++++++++++++++++++++++-
 1 file changed, 25 insertions(+), 1 deletion(-)

--
2.37.3

Comments

\( Oct. 11, 2022, 9:50 a.m. UTC | #1
Heya Thomas,

Looks mostly good, just a few nitpicks:

On Tue Oct 11, 2022 at 10:19 AM BST, Thomas Albers via Guix-patches via wrote:
> +(define-public hiredis
> +  (package
> +   (name "hiredis")
     ^
We usually have two spaces of indentation here.

> +   (source (origin
> +            (method git-fetch)
              ^
Here too.

> +            (sha256
> +             (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))

Put the hash string on a new line.

> +   (description "Library for sending commands and receiving replies to and
> +from a Redis server.  It comes with a synchronous API, asynchronous API and
> +reply parsing API.  Only the binary-safe Redis protocol is supported.")

"This package provides a library for ..." is probably better.

    -- (
Thomas Albers Raviola Oct. 11, 2022, 1:10 p.m. UTC | #2
Thanks ( for the observations. I have sent a new patch with the
corrections.
diff mbox series

Patch

diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index cf07832df7..b372423a77 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -58,6 +58,7 @@ 
 ;;; Copyright © 2022 Zhu Zihao <all_but_last@163.com>
 ;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
 ;;; Copyright © 2022 muradm <mail@muradm.net>
+;;; Copyright © 2022 Thomas Albers Raviola <thomas@thomaslabs.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2515,6 +2516,29 @@  (define-public ruby-redis
     (home-page "https://github.com/redis/redis-rb")
     (license license:expat)))

+(define-public hiredis
+  (package
+   (name "hiredis")
+   (version "1.0.2")
+   (source (origin
+            (method git-fetch)
+            (uri (git-reference
+                  (url "https://github.com/redis/hiredis")
+                  (commit (string-append "v" version))))
+            (file-name (git-file-name name version))
+            (sha256
+             (base32 "0a55zk3qrw9yl27i87h3brg2hskmmzbfda77dhq9a4if7y70xnfb"))))
+   (build-system cmake-build-system)
+   (native-inputs
+    ;; needed for testing
+    (list redis))
+   (synopsis "Minimalistic C client library for the Redis database")
+   (description "Library for sending commands and receiving replies to and
+from a Redis server.  It comes with a synchronous API, asynchronous API and
+reply parsing API.  Only the binary-safe Redis protocol is supported.")
+   (home-page "https://github.com/redis/hiredis")
+   (license license:bsd-3)))
+
 (define-public go-github-com-cupcake-rdb
   (package
     (name "go-github-com-cupcake-rdb")