diff mbox series

[bug#58426] gnu: nheko: Do not build api docs.

Message ID 20221011053002.20108-1-mike@rohleder.de
State Accepted
Headers show
Series [bug#58426] gnu: nheko: Do not build api docs. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Michael Rohleder Oct. 11, 2022, 5:30 a.m. UTC
* gnu/packages/messaging.scm (nheko)[arguments]<#:configure-flags>: Remove -DBUILD_DOCS=ON.
[native-inputs]: Remove doxygen, graphviz.
---
It doesn't make sense to build the api docs and not install them.

 gnu/packages/messaging.scm | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

Comments

Ludovic Courtès Oct. 17, 2022, 8:36 a.m. UTC | #1
Michael Rohleder <mike@rohleder.de> skribis:

> * gnu/packages/messaging.scm (nheko)[arguments]<#:configure-flags>: Remove -DBUILD_DOCS=ON.
> [native-inputs]: Remove doxygen, graphviz.
> ---
> It doesn't make sense to build the api docs and not install them.

Indeed.  :-)  Applied, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 2ce0ce2689..136b195769 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -2403,7 +2403,6 @@  (define-public nheko
       #:tests? #f                       ;no test target
       #:configure-flags
       #~(list "-DCMAKE_BUILD_TYPE=Release"
-              "-DBUILD_DOCS=ON"
               ;; Fix required because we are using a static SingleApplication
               "-DCMAKE_CXX_FLAGS= \"-DQAPPLICATION_CLASS=QApplication\" "
               ;; Compile Qml will make Nheko faster, but you will need to recompile
@@ -2469,7 +2468,7 @@  (define-public nheko
            xcb-util-wm
            zlib))
     (native-inputs
-     (list asciidoc doxygen graphviz pkg-config qttools-5))
+     (list asciidoc pkg-config qttools-5))
     (home-page "https://github.com/Nheko-Reborn/nheko")
     (synopsis "Desktop client for Matrix using Qt and C++14")
     (description "@code{Nheko} want to provide a native desktop app for the