diff mbox series

[bug#53019,1/4] gnu: Add python-coverage-5.5

Message ID 20221010213047.14134-1-goodoldpaul@autistici.org
State New
Headers show
Series [bug#53019,1/4] gnu: Add python-coverage-5.5 | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Giacomo Leidi Oct. 10, 2022, 9:30 p.m. UTC
This has been also sent to staging in https://issues.guix.gnu.org/58421.

* gnu/packages/check.scm (python-coverage-5.5): New variable.
---
 gnu/packages/check.scm | 14 ++++++++++++++
 1 file changed, 14 insertions(+)


base-commit: dbb35cd2e8a9e1d9d2f6a4425d68b0631466ff29
diff mbox series

Patch

diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 797fe71277..2758262862 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -38,6 +38,7 @@ 
 ;;; Copyright © 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2021 Hugo Lecomte <hugo.lecomte@inria.fr>
 ;;; Copyright © 2022 Maxime Devos <maximedevos@telenet.be>
+;;; Copyright © 2022 Giacomo Leidi <goodoldpaul@autistici.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1763,6 +1764,19 @@  (define-public python-coverage
 executed.")
     (license license:bsd-3)))
 
+;; TODO: This can be removed after staging is merged.
+(define-public python-coverage-5.5
+  (package
+    (inherit python-coverage)
+    (version "5.5")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "coverage" version))
+       (sha256
+        (base32
+         "0b112ly7vvplvm9l411aqknxhr7fzfyp28xhflhkcx78l3lqzrzb"))))))
+
 (define-public python-pytest-asyncio
   (package
     (name "python-pytest-asyncio")