diff mbox series

[bug#56961,v2,2/4] gnu: packages: Add go-mvdan-cc-xurls.

Message ID 20221010165709.22638-2-paren@disroot.org
State New
Headers show
Series [bug#56961,v2,1/4] gnu: packages: Add go-github-com-delthas-tcell. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch fail View Laminar job
cbaines/issue success View issue

Commit Message

\( Oct. 10, 2022, 4:57 p.m. UTC
* gnu/packages/golang.scm (go-mvdan-cc-xurls): New variable.
---
 gnu/packages/golang.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)
diff mbox series

Patch

diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index cce9c09ca8..3455861d33 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -11206,6 +11206,31 @@  (define-public go-github-com-onsi-ginkgo
 Gomega matcher library.")
     (license license:expat)))
 
+(define-public go-mvdan-cc-xurls
+  (package
+    (name "go-mvdan-cc-xurls")
+    (version "2.4.0")
+    (source (origin
+             (method git-fetch)
+             (uri (git-reference
+                   (url "https://github.com/mvdan/xurls")
+                   (commit (string-append "v" version))))
+             (file-name (git-file-name name version))
+             (sha256
+              (base32
+               "0b040nbk1vwlk1qljavh8w8fn2r243q700n6gr8j2asmnz0xq84p"))))
+    (build-system go-build-system)
+    (arguments (list #:import-path "mvdan.cc/xurls/v2"))
+    (propagated-inputs
+     (list go-golang-org-x-sync
+           go-github-com-rogpeppe-go-internal))
+    (home-page "https://mvdan.cc/xurls/v2")
+    (synopsis "Extract URLs from text in Go")
+    (description
+     "This package provides a library for extracting URLs from plain text
+using regular expressions in Go.")
+    (license license:bsd-3)))
+
 ;;;
 ;;; Avoid adding new packages to the end of this file. To reduce the chances
 ;;; of a merge conflict, place them above by existing packages with similar