diff mbox series

[bug#58414] gnu: Update guile-eris to 1.0.0.

Message ID 20221010150835.9188-1-pukkamustard@posteo.net
State Accepted
Headers show
Series [bug#58414] gnu: Update guile-eris to 1.0.0. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

pukkamustard Oct. 10, 2022, 3:08 p.m. UTC
* gnu/packages/guile-xyz.scm (guile-eris): Update to 1.0.0.
---
 gnu/packages/guile-xyz.scm | 19 ++++++++++---------
 1 file changed, 10 insertions(+), 9 deletions(-)

Comments

Christopher Baines Oct. 11, 2022, 11:10 a.m. UTC | #1
pukkamustard <pukkamustard@posteo.net> writes:

> * gnu/packages/guile-xyz.scm (guile-eris): Update to 1.0.0.
> ---
>  gnu/packages/guile-xyz.scm | 19 ++++++++++---------
>  1 file changed, 10 insertions(+), 9 deletions(-)

Thanks, pushed to master as 59911ae29442aba18bcb53233e793d8f3d264504.

Chris
Ludovic Courtès Oct. 11, 2022, 1:09 p.m. UTC | #2
Hi pukkamustard,

pukkamustard <pukkamustard@posteo.net> skribis:

> * gnu/packages/guile-xyz.scm (guile-eris): Update to 1.0.0.

Congrats on 1 point 0!  :-)

I feel bad for dropping the ball but I hope we can follow up on your
work on substitute distribution at
<https://issues.guix.gnu.org/52555#8>.

Ludo’.
pukkamustard Oct. 11, 2022, 7:15 p.m. UTC | #3
Ludovic Courtès <ludo@gnu.org> writes:

> Congrats on 1 point 0!  :-)

Thanks!

> I feel bad for dropping the ball but I hope we can follow up on your
> work on substitute distribution at
> <https://issues.guix.gnu.org/52555#8>.

No need to feel bad. On the contrary, thank you for your support and
valuable feedback on previous versions. An updated to #52555 is already
in progress. Work is going slowly, but steadily and I hope to send in an
update in a couple of weeks.

-pukkamustard
diff mbox series

Patch

diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 1760ba331e..379d9aa264 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -4485,15 +4485,15 @@  (define-public guile-sodium
 (define-public guile-eris
   (package
     (name "guile-eris")
-    (version "0.2.0")
+    (version "1.0.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://inqlab.net/git/eris.git")
+             (url "https://codeberg.org/eris/guile-eris.git")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
-       (sha256 (base32 "1ijglmwkdy1l87gj429qfjis0v8b1zlxhbyfhx5za8664h68nqka"))))
+       (sha256 (base32 "0d4wbjwwaxk0zn5gjhl86qhvk1aisgzp1vnvy4xbvrv5ydqpgyqm"))))
     (build-system gnu-build-system)
     (arguments '())
     (native-inputs
@@ -4502,17 +4502,18 @@  (define-public guile-eris
            pkg-config
            texinfo
            ;; test dependency
-           guile-srfi-180))
+           guile-srfi-180
+           guile-quickcheck))
     (inputs (list guile-3.0))
     (propagated-inputs
      (list guile-sodium))
     (synopsis "Guile implementation of the Encoding for Robust Immutable Storage (ERIS)")
     (description
-     "Guile-ERIS is the reference implementation of the Encoding for Robust
-Immutable Storage (ERIS).  ERIS allows arbitrary content to be encoded into
-uniformly sized, encrypted blocks that can be reassembled using a short
-read-capability.")
-    (home-page "https://inqlab.net/git/eris.git")
+     "Guile-ERIS is a Guile implementation of the @url{http://purl.org/eris,
+Encoding for Robust Immutable Storage (ERIS)}.  ERIS allows arbitrary content
+to be encoded into uniformly sized, encrypted blocks that can be reassembled
+using a short read-capability.")
+    (home-page "https://codeberg.org/eris/guile-eris")
     (license license:gpl3+)))
 
 (define-public guile-r6rs-protobuf