diff mbox series

[bug#58408] gnu: Add doctl.

Message ID 20221010095456.23196-1-kraai@ftbfs.org
State New
Headers show
Series [bug#58408] gnu: Add doctl. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Matthew James Kraai Oct. 10, 2022, 9:54 a.m. UTC
* gnu/packages/doctl.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk                  |  2 ++
 gnu/packages/digitalocean.scm | 58 +++++++++++++++++++++++++++++++++++
 2 files changed, 60 insertions(+)
 create mode 100644 gnu/packages/digitalocean.scm

Comments

\( Oct. 10, 2022, 11:01 a.m. UTC | #1
Hey Matthew,

On Mon Oct 10, 2022 at 10:54 AM BST, Matthew James Kraai wrote:
> * gnu/packages/doctl.scm: New file.
> * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.

You sure there's no better place to put it than a new file? Maybe
``gnu/packages/admin.scm''?

> +  #:use-module (guix download)

Since you're using git-fetch, you shouldn't need this module, right?

> +    (arguments
> +     `(#:build-flags '(,(string-append "-ldflags=-X github.com/digitalocean/doctl.Label=release"
> +                                       " -X github.com/digitalocean/doctl.Major="
> +                                       (first (string-split version #\.))
> +                                       " -X github.com/digitalocean/doctl.Minor="
> +                                       (second (string-split version #\.))
> +                                       " -X github.com/digitalocean/doctl.Patch="
> +                                       (third (string-split version #\.))))

So, this whole thing would be better formatted with "new style" arguments
(using ``list'' and gexps). Like this:

 (arguments
  (list #:build-flags
        #~(list (string-append ...))
        #| et cetera |#))

This would also allow you to remove the unquote in ``,go-1.19''. Note that only
``#:build-flags'' needs the gexp ``#~'' in this arguments list.

> +       #:go ,go-1.19

Might be best to put this above build-flags.

> +       #:import-path "github.com/digitalocean/doctl/cmd/doctl"

The import-path is usually at the top of the arguments list.

> +       #:unpack-path "github.com/digitalocean/doctl"))

And the unpack-path is usually directly after the import-path.

> +    (description
> +     "doctl provides a unified command line interface to the DigitalOcean API.")

Change ``doctl'' to ``@code{doctl}''.

    -- (
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index a013647d7e..c7423818b9 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -55,6 +55,7 @@ 
 # Copyright © 2022 Hilton Chain <hako@ultrarare.space>
 # Copyright © 2022 Alex Griffin <a@ajgrf.com>
 # Copyright © 2022 ( <paren@disroot.org>
+# Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
 #
 # This file is part of GNU Guix.
 #
@@ -206,6 +207,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/dictionaries.scm			\
   %D%/packages/diffoscope.scm			\
   %D%/packages/digest.scm			\
+  %D%/packages/digitalocean.scm			\
   %D%/packages/direct-connect.scm		\
   %D%/packages/disk.scm			\
   %D%/packages/distributed.scm			\
diff --git a/gnu/packages/digitalocean.scm b/gnu/packages/digitalocean.scm
new file mode 100644
index 0000000000..f091a1eeb6
--- /dev/null
+++ b/gnu/packages/digitalocean.scm
@@ -0,0 +1,58 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2022 Matthew James Kraai <kraai@ftbfs.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages digitalocean)
+  #:use-module ((srfi srfi-1) #:hide (zip))
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix packages)
+  #:use-module (gnu packages golang)
+  #:use-module (guix download)
+  #:use-module (guix git-download)
+  #:use-module (guix build-system go))
+
+(define-public doctl
+  (package
+    (name "doctl")
+    (version "1.83.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/digitalocean/doctl")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1narjmj3npd39gxi42k3h4zjyiaq5lvjv31vaxw8slf9h9sjhjh9"))))
+    (build-system go-build-system)
+    (arguments
+     `(#:build-flags '(,(string-append "-ldflags=-X github.com/digitalocean/doctl.Label=release"
+                                       " -X github.com/digitalocean/doctl.Major="
+                                       (first (string-split version #\.))
+                                       " -X github.com/digitalocean/doctl.Minor="
+                                       (second (string-split version #\.))
+                                       " -X github.com/digitalocean/doctl.Patch="
+                                       (third (string-split version #\.))))
+       #:go ,go-1.19
+       #:import-path "github.com/digitalocean/doctl/cmd/doctl"
+       #:install-source? #f
+       #:unpack-path "github.com/digitalocean/doctl"))
+    (synopsis "Command line client for DigitalOcean")
+    (description
+     "doctl provides a unified command line interface to the DigitalOcean API.")
+    (home-page "https://github.com/digitalocean/doctl")
+    (license license:asl2.0)))