diff mbox series

[bug#58397,2/2] gnu: emacs-ivy-pass: Don't propagate password-store.

Message ID 20221009165749.16619-2-paren@disroot.org
State Accepted
Headers show
Series gnu: emacs-password-store: Refer directly to password-store. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

\( Oct. 9, 2022, 4:57 p.m. UTC
* gnu/packages/emacs-xyz.scm (emacs-ivy-pass)[propagated-inputs]
  <password-store>: Delete it.
[synopsis, description]: Use @command when referring to pass.
---
 gnu/packages/emacs-xyz.scm | 29 ++++++++++++++---------------
 1 file changed, 14 insertions(+), 15 deletions(-)

Comments

Nicolas Goaziou Oct. 10, 2022, 4:27 p.m. UTC | #1
Hello,

"( via Guix-patches" via <guix-patches@gnu.org> writes:

> * gnu/packages/emacs-xyz.scm (emacs-ivy-pass)[propagated-inputs]
>   <password-store>: Delete it.
> [synopsis, description]: Use @command when referring to pass.

Thank you. Applied with the following changes.

> -      (source
> -       (origin
> -         (method git-fetch)
> -         (uri (git-reference
> -               (url "https://github.com/ecraven/ivy-pass")
> -               (commit commit)))
> -         (file-name (git-file-name name version))
> -         (sha256
> -          (base32
> -           "18crb4zh2pjf0cmv3b913m9vfng27girjwfqc3mk7vqd1r5a49yk"))))
> +      (source (origin
> +                (method git-fetch)
> +                (uri (git-reference
> +                      (url "https://github.com/ecraven/ivy-pass")
> +                      (commit commit)))
> +                (file-name (git-file-name name version))
> +                (sha256
> +                 (base32
> +                  "18crb4zh2pjf0cmv3b913m9vfng27girjwfqc3mk7vqd1r5a49yk"))))

This change is not warranted, so I removed it.

>        (build-system emacs-build-system)
> -      (propagated-inputs
> -       (list emacs-ivy emacs-password-store password-store))
> +      (propagated-inputs (list emacs-ivy emacs-password-store))

I think the newline removal isn't either.

>        (home-page "https://github.com/ecraven/ivy-pass")
> -      (synopsis "Ivy interface for password store (pass)")
> -      (description "This package provides an Ivy interface for working with
> -the password store @code{pass}.")
> +      (synopsis "Ivy interface to @code{pass}")
> +      (description
> +       "This package provides an Ivy interface for working with the
> +password store (@command{pass}) in Emacs.")

I used @code here too, since you're probably referring to the project's
name.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f415dc7b1..27494f2a37 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10535,23 +10535,22 @@  (define-public emacs-ivy-pass
     (package
       (name "emacs-ivy-pass")
       (version (git-version "0.1" revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/ecraven/ivy-pass")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32
-           "18crb4zh2pjf0cmv3b913m9vfng27girjwfqc3mk7vqd1r5a49yk"))))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/ecraven/ivy-pass")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "18crb4zh2pjf0cmv3b913m9vfng27girjwfqc3mk7vqd1r5a49yk"))))
       (build-system emacs-build-system)
-      (propagated-inputs
-       (list emacs-ivy emacs-password-store password-store))
+      (propagated-inputs (list emacs-ivy emacs-password-store))
       (home-page "https://github.com/ecraven/ivy-pass")
-      (synopsis "Ivy interface for password store (pass)")
-      (description "This package provides an Ivy interface for working with
-the password store @code{pass}.")
+      (synopsis "Ivy interface to @code{pass}")
+      (description
+       "This package provides an Ivy interface for working with the
+password store (@command{pass}) in Emacs.")
       (license license:gpl3))))
 
 (define-public emacs-ivy-yasnippet